Skip to content

← Actionable
High, CVSS 7.2amended

Improper validation in meraki

GHSA-6x4h-9622-fqr6

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (meraki 1.40.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI meraki

    Affected
    < 1.40.1
    Fixed in
    1.40.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.2 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

aiohttp is an asynchronous HTTP client/server framework for asyncio and Python. Improper validation made it possible for an attacker to modify the HTTP request (e.g. to insert a new header) or create a new HTTP request if the attacker controls the HTTP version. The vulnerability only occurs if the attacker can control the HTTP version of the request. This issue has been patched in version 3.9.0. meraki from version 1.40.1 requires aiohttp 3.9.0

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-6x4h-9622-fqr6

  2. Revision 1 · created ·

    Published from osv record GHSA-6x4h-9622-fqr6

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-6x4h-9622-fqr6

Advisory: Improper validation in meraki
IDs: GHSA-6x4h-9622-fqr6
Record: https://patchnext.com/advisories/ghsa-6x4h-9622-fqr6 (revision 2, source checked 26 Oct 2026, 13:12 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: meraki 1.40.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI meraki: affected < 1.40.1; fixed in 1.40.1

## Suggested inspection (read-only)
- `python -m pip show meraki`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on meraki.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-6x4h-9622-fqr6 (OSV record GHSA-6x4h-9622-fqr6 lists affected ranges: PyPI meraki >=0 <1.40.1 (fixed))
- Verified: https://github.com/advisories/GHSA-6x4h-9622-fqr6 (GitHub-reviewed advisory GHSA-6x4h-9622-fqr6 lists affected ranges: PyPI meraki >=0 <1.40.1)

Commands are suggestions: review each one before running it.

Loading voting…