Skip to content

← Public intelligence

PyPI package

mayan-edms

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

6 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Low, CVSS 2.1PyPIAmendedPublished

    Mayan EDMS has an Open Redirect through the /authentication/ file

    CVE-2025-14692 · GHSA-x37w-7p52-8f49

    Affected
    • PyPI mayan-edms >= 4.10.0, < 4.10.2; >= 4.9.0, < 4.9.7; >= 4.8.0, < 4.8.10; >= 4.7.0, < 4.7.8; < 4.6.12
    Fixed in
    4.8.104.7.84.10.24.9.74.6.12· Vendor fix available
    Issue
    A flaw has been found in Mayan EDMS up to 4.10.1. The impacted element is an unknown function of the file /authentication/. This manipulation causes open redirect. It is possible to initiate the attack remotely. The exploit has been published and may be used. Upgrading to version 4.10.2 is sufficient to resolve this issue. The affected component should be upgraded. The vendor confirms that this is "[f]ixed in version 4.10.2". Furthermore, that "[b]ackports for older versions in process and will be out as soon as their respective CI pipelines complete."

    Recommended action: Upgrade to 4.10.2, 4.9.7, 4.8.10 or 2 more by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. Low, CVSS 2.1PyPIAmendedPublished

    Mayan EDMS is vulnerable to XSS through the /authentication/ file

    CVE-2025-14691 · GHSA-774q-r975-vqwp

    Affected
    • PyPI mayan-edms >= 4.10.0, < 4.10.2; >= 4.9.0, < 4.9.7; >= 4.8.0, < 4.8.10; >= 4.7.0, < 4.7.8; < 4.6.12
    Fixed in
    4.8.104.7.84.10.24.9.74.6.12· Vendor fix available
    Issue
    A vulnerability was detected in Mayan EDMS up to 4.10.1. The affected element is an unknown function of the file /authentication/. The manipulation results in cross site scripting. The attack may be performed from remote. The exploit is now public and may be used. Upgrading to version 4.10.2 is sufficient to fix this issue. Users should upgrade the affected component. The vendor confirms that this is "[f]ixed in version 4.10.2". Furthermore, that "[b]ackports for older versions in process and will be out as soon as their respective CI pipelines complete."

    Recommended action: Upgrade to 4.10.2, 4.9.7, 4.8.10 or 2 more by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  3. Medium, CVSS 5.1PyPIAmendedPublished

    Mayan EDMS DMS XSS vulnerability

    CVE-2022-47419 · GHSA-5m6v-2xgf-qhrw

    Affected
    • PyPI mayan-edms < 4.3.6
    Fixed in
    4.3.6· Vendor fix available
    Issue
    An XSS vulnerability was discovered in the Mayan EDMS DMS. Successful XSS exploitation was observed in the in-product tagging system.

    Recommended action: Upgrade to 4.3.6 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  4. Medium, CVSS 5.1PyPIAmendedPublished

    Moderate severity vulnerability that affects mayan-edms

    CVE-2018-16407 · GHSA-5h6m-9mvx-m6c5

    Affected
    • PyPI mayan-edms < 3.0.3
    Fixed in
    3.0.3· Vendor fix available
    Issue
    An issue was discovered in Mayan EDMS before 3.0.3. The Tags app has XSS because tag label values are mishandled.

    Recommended action: Upgrade to 3.0.3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  5. Medium, CVSS 5.1PyPIAmendedPublished

    Moderate severity vulnerability that affects mayan-edms

    CVE-2018-16406 · GHSA-5r76-cjf4-c9qx

    Affected
    • PyPI mayan-edms < 3.0.2
    Fixed in
    3.0.2· Vendor fix available
    Issue
    An issue was discovered in Mayan EDMS before 3.0.2. The Cabinets app has XSS via a crafted cabinet label.

    Recommended action: Upgrade to 3.0.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  6. Medium, CVSS 5.3PyPIAmendedPublished

    mayan-edms Cross-site Scripting vulnerability

    CVE-2018-16405 · GHSA-fpcv-j2q9-vqhw

    Affected
    • PyPI mayan-edms < 3.0.2
    Fixed in
    3.0.2· Vendor fix available
    Issue
    An issue was discovered in Mayan EDMS before 3.0.2. The Appearance app sets window.location directly, leading to XSS.

    Recommended action: Upgrade to 3.0.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →