Mayan EDMS has an Open Redirect through the /authentication/ file
CVE-2025-14692GHSA-x37w-7p52-8f49
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (mayan-edms 4.10.2, 4.9.7, 4.8.10, 4.7.8, 4.6.12), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI mayan-edms
- Affected
- >= 4.10.0, < 4.10.2>= 4.9.0, < 4.9.7>= 4.8.0, < 4.8.10>= 4.7.0, < 4.7.8< 4.6.12
- Fixed in
- 4.8.10, 4.7.8, 4.10.2, 4.9.7, 4.6.12
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-x37w-7p52-8f49 lists affected ranges: PyPI mayan-edms >=4.10.0 =4.9.0 =4.8.0 =4.7.0 =0 <4.6.12 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-x37w-7p52-8f49 lists affected ranges: PyPI mayan-edms >=4.10.0 =4.9.0 =4.8.0 =4.7.0 =0 <4.6.12
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 2.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:P · score source
- EPSS
- CVE-2025-14692: 0.46% estimated exploitation activity in the next 30 days; percentile 39.86 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A flaw has been found in Mayan EDMS up to 4.10.1. The impacted element is an unknown function of the file /authentication/. This manipulation causes open redirect. It is possible to initiate the attack remotely. The exploit has been published and may be used. Upgrading to version 4.10.2 is sufficient to resolve this issue. The affected component should be upgraded. The vendor confirms that this is "[f]ixed in version 4.10.2". Furthermore, that "[b]ackports for older versions in process and will be out as soon as their respective CI pipelines complete."
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-x37w-7p52-8f49
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-x37w-7p52-8f49
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-14692 Advisory: Mayan EDMS has an Open Redirect through the /authentication/ file IDs: CVE-2025-14692, GHSA-x37w-7p52-8f49 Record: https://patchnext.com/advisories/cve-2025-14692 (revision 3, source checked 26 Oct 2026, 13:44 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 2.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: mayan-edms 4.10.2, 4.9.7, 4.8.10, 4.7.8, 4.6.12. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI mayan-edms: affected >= 4.10.0, < 4.10.2; >= 4.9.0, < 4.9.7; >= 4.8.0, < 4.8.10; >= 4.7.0, < 4.7.8; < 4.6.12; fixed in 4.8.10, 4.7.8, 4.10.2, 4.9.7, 4.6.12 ## Suggested inspection (read-only) - `python -m pip show mayan-edms`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on mayan-edms. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-x37w-7p52-8f49 (OSV record GHSA-x37w-7p52-8f49 lists affected ranges: PyPI mayan-edms >=4.10.0 =4.9.0 =4.8.0 =4.7.0 =0 <4.6.12 (fixed)) - Verified: https://github.com/advisories/GHSA-x37w-7p52-8f49 (GitHub-reviewed advisory GHSA-x37w-7p52-8f49 lists affected ranges: PyPI mayan-edms >=4.10.0 =4.9.0 =4.8.0 =4.7.0 =0 <4.6.12) Commands are suggestions: review each one before running it.
Loading voting…