Medium, CVSS 6.1PyPIAmendedPublished
MapProxy vulnerable to cross-site scripting in demo service
CVE-2017-1000426 · GHSA-g4rw-82hq-8jpr
- Affected
- PyPI mapproxy < 1.11.1
- Fixed in
- 1.11.1· Vendor fix available
- Issue
- MapProxy version 1.11.1 and older are vulnerable to cross-site scripting in the demo service resulting in possible information disclosure. An incomplete fix was released in v1.10.4, and a complete fix was released in v1.11.1.
Recommended action: Upgrade to 1.11.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.