MapProxy vulnerable to cross-site scripting in demo service
CVE-2017-1000426GHSA-g4rw-82hq-8jpr
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (mapproxy 1.11.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI mapproxy
- Affected
- < 1.11.1
- Fixed in
- 1.11.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-g4rw-82hq-8jpr lists affected ranges: PyPI mapproxy >=0 <1.11.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-g4rw-82hq-8jpr lists affected ranges: PyPI mapproxy >=0 <1.11.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2017-1000426: 0.78% estimated exploitation activity in the next 30 days; percentile 56.07 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
MapProxy version 1.11.1 and older are vulnerable to cross-site scripting in the demo service resulting in possible information disclosure. An incomplete fix was released in v1.10.4, and a complete fix was released in v1.11.1.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-g4rw-82hq-8jpr
- Revision 1 · created ·
Published from osv record GHSA-g4rw-82hq-8jpr
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2017-1000426 Advisory: MapProxy vulnerable to cross-site scripting in demo service IDs: CVE-2017-1000426, GHSA-g4rw-82hq-8jpr Record: https://patchnext.com/advisories/cve-2017-1000426 (revision 2, source checked 26 Oct 2026, 13:12 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: mapproxy 1.11.1. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI mapproxy: affected < 1.11.1; fixed in 1.11.1 ## Suggested inspection (read-only) - `python -m pip show mapproxy`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on mapproxy. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-g4rw-82hq-8jpr (OSV record GHSA-g4rw-82hq-8jpr lists affected ranges: PyPI mapproxy >=0 <1.11.1 (fixed)) - Verified: https://github.com/advisories/GHSA-g4rw-82hq-8jpr (GitHub-reviewed advisory GHSA-g4rw-82hq-8jpr lists affected ranges: PyPI mapproxy >=0 <1.11.1) Commands are suggestions: review each one before running it.
Loading voting…