High, CVSS 8.8PyPIAmendedPublished
RunGptLLM class in LlamaIndex has a command injection
CVE-2024-4181 · GHSA-pw38-xv9x-h8ch
- Affected
- PyPI llama-index-llms-rungpt < 0.1.3
- Fixed in
- 0.1.3· Vendor fix available
- Issue
- A command injection vulnerability exists in the RunGptLLM class of the llamaindex library, version 0.9.47, used by the RunGpt framework from JinaAI to connect to Language Learning Models (LLMs). The vulnerability arises from the improper use of the eval function, allowing a malicious or compromised LLM hosting provider to execute arbitrary commands on the client's machine. This issue was fixed in version 0.10.13. The exploitation of this vulnerability could lead to a hosting provider gaining full control over client machines.
Recommended action: Upgrade to 0.1.3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.