Skip to content

← Actionable
High, CVSS 8.8amended

RunGptLLM class in LlamaIndex has a command injection

CVE-2024-4181GHSA-pw38-xv9x-h8ch

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (llama-index 0.10.13; llama-index-llms-rungpt 0.1.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.8 · CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
EPSS
  • CVE-2024-4181: 2.14% estimated exploitation activity in the next 30 days; percentile 82.03 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A command injection vulnerability exists in the RunGptLLM class of the llamaindex library, version 0.9.47, used by the RunGpt framework from JinaAI to connect to Language Learning Models (LLMs). The vulnerability arises from the improper use of the eval function, allowing a malicious or compromised LLM hosting provider to execute arbitrary commands on the client's machine. This issue was fixed in version 0.10.13. The exploitation of this vulnerability could lead to a hosting provider gaining full control over client machines.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-pw38-xv9x-h8ch

  2. Revision 1 · created ·

    Published from osv record GHSA-pw38-xv9x-h8ch

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-4181

Advisory: RunGptLLM class in LlamaIndex has a command injection
IDs: CVE-2024-4181, GHSA-pw38-xv9x-h8ch
Record: https://patchnext.com/advisories/cve-2024-4181 (revision 2, source checked 26 Oct 2026, 13:13 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: llama-index 0.10.13; llama-index-llms-rungpt 0.1.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI llama-index: affected < 0.10.13; fixed in 0.10.13
- PyPI llama-index-llms-rungpt: affected < 0.1.3; fixed in 0.1.3

## Suggested inspection (read-only)
- `python -m pip show llama-index`: prints the installed version. Run with the environment that serves production active.
- `python -m pip show llama-index-llms-rungpt`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on llama-index, llama-index-llms-rungpt.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-pw38-xv9x-h8ch (OSV record GHSA-pw38-xv9x-h8ch lists affected ranges: PyPI llama-index >=0 =0 <0.1.3 (fixed))
- Verified: https://github.com/advisories/GHSA-pw38-xv9x-h8ch (GitHub-reviewed advisory GHSA-pw38-xv9x-h8ch lists affected ranges: PyPI llama-index >=0 =0 <0.1.3)

Commands are suggestions: review each one before running it.

Loading voting…