Skip to content

← Public intelligence

PyPI package

langgraph-store-mongodb

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.7PyPIPublished

    LangChain MongoDB has NoSQL Operator Injection in MongoDBSaver.list() leading to cross-tenant data exposure

    CVE-2026-55253 · GHSA-533j-2v4q-mw5h

    Affected
    • PyPI langgraph-store-mongodb < 0.4.0
    Fixed in
    0.4.0· Vendor fix available
    Issue
    Executive Summary A NoSQL injection issue exists in the langgraph-checkpoint-mongodb and langgraph-store-mongodb libraries. MongoDBSaver.list() and MongoDBStore.search() methods accept a filter parameter that is incorporated into MongoDB queries without sufficient validation. Because MongoDB query operator keys (those prefixed with $) are not rejected during filter construction, a caller with control of the filter input can embed MongoDB query operators directly into the query. --- CVSS Details CVSS 4.0 | Field | Value | |---|---| | CVSS Version | 4.0 | | Vector String | CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:N/SC:H/SI:N/SA:N | | Base Score | 7.1 (High) | | Metric | Value | Rationale | |---|---|---| | Attack Vector (AV) | Network | Triggerable remotely via API | | Attack Complexity (AC) | Low | No special conditions required | | Attack Requirements (AT) | None | No prerequisite deployment or execution conditions | | Privileges Required (PR) | Low | Authenticated caller of the…

    Recommended action: Upgrade to 0.4.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →