LangChain MongoDB has NoSQL Operator Injection in MongoDBSaver.list() leading to cross-tenant data exposure
CVE-2026-55253GHSA-533j-2v4q-mw5h
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (langgraph-store-mongodb 0.4.0; langgraph-checkpoint-mongodb 0.3.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 0.4.0
- Fixed in
- 0.4.0
PyPI langgraph-checkpoint-mongodb
- Affected
- < 0.3.0
- Fixed in
- 0.3.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-533j-2v4q-mw5h lists affected ranges: PyPI langgraph-checkpoint-mongodb >=0 =0 <0.4.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.7 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N
- EPSS
- CVE-2026-55253: 0.53% estimated exploitation activity in the next 30 days; percentile 44.96 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Executive Summary A NoSQL injection issue exists in the langgraph-checkpoint-mongodb and langgraph-store-mongodb libraries. MongoDBSaver.list() and MongoDBStore.search() methods accept a filter parameter that is incorporated into MongoDB queries without sufficient validation. Because MongoDB query operator keys (those prefixed with $) are not rejected during filter construction, a caller with control of the filter input can embed MongoDB query operators directly into the query. --- CVSS Details CVSS 4.0 | Field | Value | |---|---| | CVSS Version | 4.0 | | Vector String | CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:N/SC:H/SI:N/SA:N | | Base Score | 7.1 (High) | | Metric | Value | Rationale | |---|---|---| | Attack Vector (AV) | Network | Triggerable remotely via API | | Attack Complexity (AC) | Low | No special conditions required | | Attack Requirements (AT) | None | No prerequisite deployment or execution conditions | | Privileges Required (PR) | Low | Authenticated caller of the…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-533j-2v4q-mw5h
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-55253 Advisory: LangChain MongoDB has NoSQL Operator Injection in MongoDBSaver.list() leading to cross-tenant data exposure IDs: CVE-2026-55253, GHSA-533j-2v4q-mw5h Record: https://patchnext.com/advisories/cve-2026-55253 (revision 1, source checked 26 Oct 2026, 13:50 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: langgraph-store-mongodb 0.4.0; langgraph-checkpoint-mongodb 0.3.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI langgraph-store-mongodb: affected < 0.4.0; fixed in 0.4.0 - PyPI langgraph-checkpoint-mongodb: affected < 0.3.0; fixed in 0.3.0 ## Suggested inspection (read-only) - `python -m pip show langgraph-store-mongodb`: prints the installed version. Run with the environment that serves production active. - `python -m pip show langgraph-checkpoint-mongodb`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on langgraph-store-mongodb, langgraph-checkpoint-mongodb. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-533j-2v4q-mw5h (GitHub-reviewed advisory GHSA-533j-2v4q-mw5h lists affected ranges: PyPI langgraph-checkpoint-mongodb >=0 =0 <0.4.0) Commands are suggestions: review each one before running it.
Loading voting…