Skip to content

← Public intelligence

PyPI package

kubectl-mcp-server

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Critical, CVSS 9.8PyPIAmendedPublished

    Open Source Kubectl MCP Server vulnerable to arbitrary code execution via user interaction with crafted HTML page

    CVE-2025-65719 · GHSA-94gr-w3q5-rfqr

    Affected
    • PyPI kubectl-mcp-server < 1.2.0
    Fixed in
    1.2.0· Vendor fix available
    Issue
    An issue in Open Source Kubectl MCP Server v1.1.1 allows attackers to execute arbitrary code on a victim system via user interaction with a crafted HTML page.

    Recommended action: Upgrade to 1.2.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.com (1)osv.dev (2)Source checked Evidence →