Open Source Kubectl MCP Server vulnerable to arbitrary code execution via user interaction with crafted HTML page
CVE-2025-65719GHSA-94gr-w3q5-rfqr
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (kubectl-mcp-server 1.2.0; kubectl-mcp-server 1.2.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI kubectl-mcp-server
- Affected
- < 1.2.0
- Fixed in
- 1.2.0
- Affected
- < 1.2.0
- Fixed in
- 1.2.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-94gr-w3q5-rfqr lists affected ranges: npm kubectl-mcp-server >=0 =0 <1.2.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-94gr-w3q5-rfqr lists affected ranges: npm kubectl-mcp-server >=0 =0 <1.2.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2025-65719: 0.58% estimated exploitation activity in the next 30 days; percentile 47.65 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
An issue in Open Source Kubectl MCP Server v1.1.1 allows attackers to execute arbitrary code on a victim system via user interaction with a crafted HTML page.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 5 · amended ·
Amended from osv record GHSA-94gr-w3q5-rfqr
- Revision 4 · amended ·
Amended from ghsa record GHSA-94gr-w3q5-rfqr
- Revision 3 · amended ·
Amended from ghsa record GHSA-94gr-w3q5-rfqr
- Revision 2 · amended ·
Amended from osv record GHSA-94gr-w3q5-rfqr
- Revision 1 · created ·
Published from ghsa record GHSA-94gr-w3q5-rfqr
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-65719 Advisory: Open Source Kubectl MCP Server vulnerable to arbitrary code execution via user interaction with crafted HTML page IDs: CVE-2025-65719, GHSA-94gr-w3q5-rfqr Record: https://patchnext.com/advisories/cve-2025-65719 (revision 5, source checked 28 Oct 2026, 06:00 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: kubectl-mcp-server 1.2.0; kubectl-mcp-server 1.2.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI kubectl-mcp-server: affected < 1.2.0; fixed in 1.2.0 - npm kubectl-mcp-server: affected < 1.2.0; fixed in 1.2.0 ## Suggested inspection (read-only) - `python -m pip show kubectl-mcp-server`: prints the installed version. Run with the environment that serves production active. - `npm ls kubectl-mcp-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on kubectl-mcp-server. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-94gr-w3q5-rfqr (GitHub-reviewed advisory GHSA-94gr-w3q5-rfqr lists affected ranges: npm kubectl-mcp-server >=0 =0 <1.2.0) - Verified: https://osv.dev/vulnerability/GHSA-94gr-w3q5-rfqr (OSV record GHSA-94gr-w3q5-rfqr lists affected ranges: npm kubectl-mcp-server >=0 =0 <1.2.0 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…