Skip to content

← Public intelligence

PyPI package

koji

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

4 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 5.4PyPIAmendedPublished

    Koji Cross-site Scripting

    CVE-2024-9427 · GHSA-g2vg-8hfg-79vj

    Affected
    • PyPI koji >= 1.35.0, <= 1.35.0; >= 1.34.0, < 1.34.3; < 1.33.2
    Fixed in
    1.35.11.33.21.34.3· Vendor fix available
    Issue
    A vulnerability in Koji was found. An unsanitized input allows for an XSS attack. Javascript code from a malicious link could be reflected in the resulting web page. It is not expected to be able to submit an action or make a change in Koji due to existing XSS protections in the code.

    Recommended action: Upgrade to 1.35.1, 1.34.3 or 1.33.2 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. High, CVSS 7.1PyPIAmendedPublished

    koji hub allows arbitrary upload destinations

    CVE-2019-17109 · GHSA-7498-c9fm-g64p

    Affected
    • PyPI koji >= 1.14.0, < 1.14.3; >= 1.15.0, < 1.15.3; >= 1.16.0, < 1.16.3; >= 1.17.0, < 1.17.1; >= 1.18.0, < 1.18.1
    Fixed in
    1.14.31.17.11.15.31.18.11.16.3· Vendor fix available
    Issue
    The way that the hub code validates upload paths allows for an attacker to choose an arbitrary destination for the uploaded file. Uploading still requires login. However, an attacker with credentials could damage the integrity of the Koji system. Workaround There is no known workaround. All Koji admins are encouraged to update to a fixed version as soon as possible. Fix Koji versions 1.14.3, 1.15.3, 1.16.3, 1.17.1, and 1.18.1 all include patches to solve this vulnerability.

    Recommended action: Upgrade to 1.18.1, 1.17.1, 1.16.3 or 2 more by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  3. High, CVSS 7.5PyPIAmendedPublished

    Koji blacklisted paths workaround

    CVE-2017-1002153 · GHSA-vwp5-w4rq-g4cc

    Affected
    • PyPI koji < 1.15.0
    Fixed in
    1.15.0· Vendor fix available
    Issue
    Koji 1.13.0 does not properly validate SCM paths, allowing an attacker to work around blacklisted paths for build submission.

    Recommended action: Upgrade to 1.15.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  4. Critical, CVSS 9.3PyPIAmendedPublished

    Koji hub call does not perform correct access checks

    CVE-2018-1002150 · GHSA-6mww-xvh7-fq4f

    Affected
    • PyPI koji >= 1.12, <= 1.12; >= 1.13, <= 1.13; >= 1.14, <= 1.14; >= 1.15, <= 1.15
    Fixed in
    1.15.11.14.11.13.11.12.1· Vendor fix available
    Issue
    Koji version 1.12, 1.13, 1.14 and 1.15 contain an incorrect access control vulnerability resulting in arbitrary filesystem read/write access. This vulnerability has been fixed in versions 1.12.1, 1.13.1, 1.14.1 and 1.15.1.

    Recommended action: Upgrade to 1.15.1, 1.14.1, 1.13.1 or 1.12.1 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →