koji hub allows arbitrary upload destinations
CVE-2019-17109GHSA-7498-c9fm-g64p
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (koji 1.18.1, 1.17.1, 1.16.3, 1.15.3, 1.14.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI koji
- Affected
- >= 1.14.0, < 1.14.3>= 1.15.0, < 1.15.3>= 1.16.0, < 1.16.3>= 1.17.0, < 1.17.1>= 1.18.0, < 1.18.1
- Fixed in
- 1.14.3, 1.17.1, 1.15.3, 1.18.1, 1.16.3
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-7498-c9fm-g64p lists affected ranges: PyPI koji >=1.14.0 =1.15.0 =1.16.0 =1.17.0 =1.18.0 <1.18.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7498-c9fm-g64p lists affected ranges: PyPI koji >=1.14.0 =1.15.0 =1.16.0 =1.17.0 =1.18.0 <1.18.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 7.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2019-17109: 3.15% estimated exploitation activity in the next 30 days; percentile 87.97 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The way that the hub code validates upload paths allows for an attacker to choose an arbitrary destination for the uploaded file. Uploading still requires login. However, an attacker with credentials could damage the integrity of the Koji system. Workaround There is no known workaround. All Koji admins are encouraged to update to a fixed version as soon as possible. Fix Koji versions 1.14.3, 1.15.3, 1.16.3, 1.17.1, and 1.18.1 all include patches to solve this vulnerability.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-7498-c9fm-g64p
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-7498-c9fm-g64p
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2019-17109 Advisory: koji hub allows arbitrary upload destinations IDs: CVE-2019-17109, GHSA-7498-c9fm-g64p Record: https://patchnext.com/advisories/cve-2019-17109 (revision 3, source checked 26 Oct 2026, 13:20 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: koji 1.18.1, 1.17.1, 1.16.3, 1.15.3, 1.14.3. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI koji: affected >= 1.14.0, < 1.14.3; >= 1.15.0, < 1.15.3; >= 1.16.0, < 1.16.3; >= 1.17.0, < 1.17.1; >= 1.18.0, < 1.18.1; fixed in 1.14.3, 1.17.1, 1.15.3, 1.18.1, 1.16.3 ## Suggested inspection (read-only) - `python -m pip show koji`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on koji. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-7498-c9fm-g64p (OSV record GHSA-7498-c9fm-g64p lists affected ranges: PyPI koji >=1.14.0 =1.15.0 =1.16.0 =1.17.0 =1.18.0 <1.18.1 (fixed)) - Verified: https://github.com/advisories/GHSA-7498-c9fm-g64p (GitHub-reviewed advisory GHSA-7498-c9fm-g64p lists affected ranges: PyPI koji >=1.14.0 =1.15.0 =1.16.0 =1.17.0 =1.18.0 <1.18.1) Commands are suggestions: review each one before running it.
Loading voting…