Skip to content

← Public intelligence

PyPI package

keystonemiddleware

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

3 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 8.2PyPIAmendedPublished

    OpenStack keystonemiddleware does not verify certificate

    CVE-2014-7144 · GHSA-7f2c-vp52-gmfw

    Affected
    • PyPI keystonemiddleware < 0.11.0; >= 1.0, < 1.2.0
    Fixed in
    1.2.00.11.0· Vendor fix available
    Issue
    OpenStack keystonemiddleware (formerly python-keystoneclient) 0.x before 0.11.0 and 1.x before 1.2.0 disables certification verification when the "insecure" option is set in a paste configuration (paste.ini) file regardless of the value, which allows remote attackers to conduct man-in-the-middle attacks via a crafted certificate.

    Recommended action: Upgrade to 1.2.0 or 0.11.0 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. High, CVSS 8.7PyPIAmendedPublished

    OpenStack keystonemiddleware and python-keystoneclient vulnerable to man-in-the-middle attacks

    CVE-2015-1852 · GHSA-p9wq-mjh8-q72m

    Affected
    • PyPI keystonemiddleware < 1.6.0
    Fixed in
    1.6.0· Vendor fix available
    Issue
    The s3token middleware in OpenStack keystonemiddleware before 1.6.0 and python-keystoneclient before 1.4.0 disables certification verification when the "insecure" option is set in a paste configuration (paste.ini) file regardless of the value, which allows remote attackers to conduct man-in-the-middle attacks via a crafted certificate, a different vulnerability than CVE-2014-7144.

    Recommended action: Upgrade to 1.6.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  3. High, CVSS 8.6PyPIAmendedPublished

    OpenStack Identity Keystone and keystonemiddleware Insufficiently Protected Credentials

    CVE-2015-7546 · GHSA-8c4w-v65p-jvcv

    Affected
    • PyPI keystonemiddleware >= 2.4.0, < 4.1.0; < 1.5.4; >= 1.6.0, < 2.3.3
    Fixed in
    2.3.31.5.44.1.0· Vendor fix available
    Issue
    The identity service in OpenStack Identity (Keystone) before 2015.1.3 (Kilo) and 8.0.x before 8.0.2 (Liberty) and keystonemiddleware (formerly python-keystoneclient) before 1.5.4 (Kilo) and Liberty before 2.3.3 does not properly invalidate authorization tokens when using the PKI or PKIZ token providers, which allows remote authenticated users to bypass intended access restrictions and gain access to cloud resources by manipulating byte fields within a revoked token.

    Recommended action: Upgrade to 4.1.0, 2.3.3 or 1.5.4 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →