OpenStack keystonemiddleware does not verify certificate
CVE-2014-7144GHSA-7f2c-vp52-gmfw
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (python-keystoneclient 1.2.0, 0.11.0; keystonemiddleware 1.2.0, 0.11.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 0.11.0>= 1.0, < 1.2.0
- Fixed in
- 1.2.0, 0.11.0
PyPI keystonemiddleware
- Affected
- < 0.11.0>= 1.0, < 1.2.0
- Fixed in
- 1.2.0, 0.11.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-7f2c-vp52-gmfw lists affected ranges: PyPI keystonemiddleware >=0 =1.0 =0 =1.0 <1.2.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7f2c-vp52-gmfw lists affected ranges: PyPI keystonemiddleware >=0 =1.0 =0 =1.0 <1.2.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.2 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2014-7144: 1.90% estimated exploitation activity in the next 30 days; percentile 79.72 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
OpenStack keystonemiddleware (formerly python-keystoneclient) 0.x before 0.11.0 and 1.x before 1.2.0 disables certification verification when the "insecure" option is set in a paste configuration (paste.ini) file regardless of the value, which allows remote attackers to conduct man-in-the-middle attacks via a crafted certificate.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-7f2c-vp52-gmfw
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-7f2c-vp52-gmfw
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2014-7144 Advisory: OpenStack keystonemiddleware does not verify certificate IDs: CVE-2014-7144, GHSA-7f2c-vp52-gmfw Record: https://patchnext.com/advisories/cve-2014-7144 (revision 3, source checked 26 Oct 2026, 13:20 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: python-keystoneclient 1.2.0, 0.11.0; keystonemiddleware 1.2.0, 0.11.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI python-keystoneclient: affected < 0.11.0; >= 1.0, < 1.2.0; fixed in 1.2.0, 0.11.0 - PyPI keystonemiddleware: affected < 0.11.0; >= 1.0, < 1.2.0; fixed in 1.2.0, 0.11.0 ## Suggested inspection (read-only) - `python -m pip show python-keystoneclient`: prints the installed version. Run with the environment that serves production active. - `python -m pip show keystonemiddleware`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on python-keystoneclient, keystonemiddleware. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-7f2c-vp52-gmfw (OSV record GHSA-7f2c-vp52-gmfw lists affected ranges: PyPI keystonemiddleware >=0 =1.0 =0 =1.0 <1.2.0 (fixed)) - Verified: https://github.com/advisories/GHSA-7f2c-vp52-gmfw (GitHub-reviewed advisory GHSA-7f2c-vp52-gmfw lists affected ranges: PyPI keystonemiddleware >=0 =1.0 =0 =1.0 <1.2.0) Commands are suggestions: review each one before running it.
Loading voting…