Skip to content

← Public intelligence

PyPI package

jupyterhub-kubespawner

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.6PyPIAmendedPublished

    Possible pod name collisions in jupyterhub-kubespawner

    CVE-2020-15110 · GHSA-v7m9-9497-p9gr

    Affected
    • PyPI jupyterhub-kubespawner <= 0.11.1
    Fixed in
    0.12.0· Vendor fix available
    Issue
    Impact What kind of vulnerability is it? Who is impacted? JupyterHub deployments using: - KubeSpawner <= 0.11.1 (e.g. zero-to-jupyterhub 0.9.0) and - enabled namedservers (not default), and - an Authenticator that allows: - usernames with hyphens or other characters that require escape (e.g. user-hyphen or user@email), and - usernames which may match other usernames up to but not including the escaped character (e.g. user in the above cases) In this circumstance, certain usernames will be able to craft particular server names which will grant them access to the default server of other users who have matching usernames. Patches Has the problem been patched? What versions should users upgrade to? Patch will be released in kubespawner 0.12 and zero-to-jupyterhub 0.9.1 Workarounds Is there a way for users to fix or remediate the vulnerability without upgrading? KubeSpawner Specify configuration: for KubeSpawner Note for KubeSpawner: this configuration will behave differently before and…

    Recommended action: Upgrade to 0.12.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →