Skip to content

← Actionable
High, CVSS 7.6amended

Possible pod name collisions in jupyterhub-kubespawner

CVE-2020-15110GHSA-v7m9-9497-p9gr

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (jupyterhub-kubespawner 0.12.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.6 · CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2020-15110: 1.11% estimated exploitation activity in the next 30 days; percentile 66.06 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact What kind of vulnerability is it? Who is impacted? JupyterHub deployments using: - KubeSpawner <= 0.11.1 (e.g. zero-to-jupyterhub 0.9.0) and - enabled namedservers (not default), and - an Authenticator that allows: - usernames with hyphens or other characters that require escape (e.g. user-hyphen or user@email), and - usernames which may match other usernames up to but not including the escaped character (e.g. user in the above cases) In this circumstance, certain usernames will be able to craft particular server names which will grant them access to the default server of other users who have matching usernames. Patches Has the problem been patched? What versions should users upgrade to? Patch will be released in kubespawner 0.12 and zero-to-jupyterhub 0.9.1 Workarounds Is there a way for users to fix or remediate the vulnerability without upgrading? KubeSpawner Specify configuration: for KubeSpawner Note for KubeSpawner: this configuration will behave differently before and…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-v7m9-9497-p9gr

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-v7m9-9497-p9gr

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-15110

Advisory: Possible pod name collisions in jupyterhub-kubespawner
IDs: CVE-2020-15110, GHSA-v7m9-9497-p9gr
Record: https://patchnext.com/advisories/cve-2020-15110 (revision 3, source checked 26 Oct 2026, 13:17 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: jupyterhub-kubespawner 0.12.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI jupyterhub-kubespawner: affected <= 0.11.1; fixed in 0.12.0

## Suggested inspection (read-only)
- `python -m pip show jupyterhub-kubespawner`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on jupyterhub-kubespawner.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-v7m9-9497-p9gr (OSV record GHSA-v7m9-9497-p9gr lists affected ranges: PyPI jupyterhub-kubespawner >=0 <0.12.0 (fixed))
- Verified: https://github.com/advisories/GHSA-v7m9-9497-p9gr (GitHub-reviewed advisory GHSA-v7m9-9497-p9gr lists affected ranges: PyPI jupyterhub-kubespawner >=0 <=0.11.1)

Commands are suggestions: review each one before running it.

Loading voting…