Skip to content

← Public intelligence

PyPI package

jupyterhub-firstuseauthenticator

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Critical, CVSS 9.3PyPIAmendedPublished

    Improper Access Control in jupyterhub-firstuseauthenticator

    CVE-2021-41194 · GHSA-5xvc-vgmp-jgc3

    Affected
    • PyPI jupyterhub-firstuseauthenticator < 1.0.0
    Fixed in
    1.0.0· Vendor fix available
    Issue
    Impact When JupyterHub is used with FirstUseAuthenticator, the vulnerability allows unauthorized access to any user's account if createusers=True and the username is known or guessed. Patches Upgrade to jupyterhub-firstuseauthenticator to 1.0, or apply patch https://github.com/jupyterhub/firstuseauthenticator/pull/38.patch Workarounds If you cannot upgrade, there is no complete workaround, but it can be mitigated. If you cannot upgrade yet, you can disable user creation with c.FirstUseAuthenticator.createusers = False, which will only allow login with fully normalized usernames for already existing users prior to jupyterhub-firstuserauthenticator 1.0. If any users have never logged in with their normalized username (i.e. lowercase), they will still be vulnerable until you can patch or upgrade.

    Recommended action: Upgrade to 1.0.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →