Improper Access Control in jupyterhub-firstuseauthenticator
CVE-2021-41194GHSA-5xvc-vgmp-jgc3
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (jupyterhub-firstuseauthenticator 1.0.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI jupyterhub-firstuseauthenticator
- Affected
- < 1.0.0
- Fixed in
- 1.0.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-5xvc-vgmp-jgc3 lists affected ranges: PyPI jupyterhub-firstuseauthenticator >=0 <1.0.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5xvc-vgmp-jgc3 lists affected ranges: PyPI jupyterhub-firstuseauthenticator >=0 <1.0.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 9.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2021-41194: 1.37% estimated exploitation activity in the next 30 days; percentile 71.89 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact When JupyterHub is used with FirstUseAuthenticator, the vulnerability allows unauthorized access to any user's account if createusers=True and the username is known or guessed. Patches Upgrade to jupyterhub-firstuseauthenticator to 1.0, or apply patch https://github.com/jupyterhub/firstuseauthenticator/pull/38.patch Workarounds If you cannot upgrade, there is no complete workaround, but it can be mitigated. If you cannot upgrade yet, you can disable user creation with c.FirstUseAuthenticator.createusers = False, which will only allow login with fully normalized usernames for already existing users prior to jupyterhub-firstuserauthenticator 1.0. If any users have never logged in with their normalized username (i.e. lowercase), they will still be vulnerable until you can patch or upgrade.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-5xvc-vgmp-jgc3
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-5xvc-vgmp-jgc3
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-41194 Advisory: Improper Access Control in jupyterhub-firstuseauthenticator IDs: CVE-2021-41194, GHSA-5xvc-vgmp-jgc3 Record: https://patchnext.com/advisories/cve-2021-41194 (revision 3, source checked 26 Oct 2026, 13:18 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: jupyterhub-firstuseauthenticator 1.0.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI jupyterhub-firstuseauthenticator: affected < 1.0.0; fixed in 1.0.0 ## Suggested inspection (read-only) - `python -m pip show jupyterhub-firstuseauthenticator`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on jupyterhub-firstuseauthenticator. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-5xvc-vgmp-jgc3 (OSV record GHSA-5xvc-vgmp-jgc3 lists affected ranges: PyPI jupyterhub-firstuseauthenticator >=0 <1.0.0 (fixed)) - Verified: https://github.com/advisories/GHSA-5xvc-vgmp-jgc3 (GitHub-reviewed advisory GHSA-5xvc-vgmp-jgc3 lists affected ranges: PyPI jupyterhub-firstuseauthenticator >=0 <1.0.0) Commands are suggestions: review each one before running it.
Loading voting…