Critical, CVSS 9.0PyPIAmendedPublished
TigerVNC accessible via the network and not just via a UNIX socket as intended
CVE-2025-32428 · GHSA-vrq4-9hc3-cgp7
- Affected
- PyPI jupyter-remote-desktop-proxy >= 3.0.0, < 3.0.1
- Fixed in
- 3.0.1· Vendor fix available
- Issue
- `jupyter-remote-desktop-proxy` was meant to rely on UNIX sockets readable only by the current user since version 3.0.0, but when used with TigerVNC, the VNC server started by `jupyter-remote-desktop-proxy` were still accessible via the network. This vulnerability does not affect users having TurboVNC as the `vncserver` executable. Credits This vulnerability was identified by Arne Gottwald at University of Göttingen and analyzed, reported, and reviewed by @frejanordsiek.
Recommended action: Upgrade to 3.0.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.