Skip to content

← Actionable
Critical, CVSS 9.0amended

TigerVNC accessible via the network and not just via a UNIX socket as intended

CVE-2025-32428GHSA-vrq4-9hc3-cgp7

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (jupyter-remote-desktop-proxy 3.0.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.0 · CVSS:4.0/AV:A/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H · score source
EPSS
  • CVE-2025-32428: 0.92% estimated exploitation activity in the next 30 days; percentile 60.24 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary `jupyter-remote-desktop-proxy` was meant to rely on UNIX sockets readable only by the current user since version 3.0.0, but when used with TigerVNC, the VNC server started by `jupyter-remote-desktop-proxy` were still accessible via the network. This vulnerability does not affect users having TurboVNC as the `vncserver` executable.

Credits This vulnerability was identified by Arne Gottwald at University of Göttingen and analyzed, reported, and reviewed by @frejanordsiek.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 5 · amended ·

    Amended from osv record GHSA-vrq4-9hc3-cgp7

  2. Revision 4 · amended ·

    Amended from ghsa record GHSA-vrq4-9hc3-cgp7

  3. Revision 3 · amended ·

    Amended from ghsa record GHSA-vrq4-9hc3-cgp7

  4. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  5. Revision 1 · created ·

    Published from osv record GHSA-vrq4-9hc3-cgp7

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-32428

Advisory: TigerVNC accessible via the network and not just via a UNIX socket as intended
IDs: CVE-2025-32428, GHSA-vrq4-9hc3-cgp7
Record: https://patchnext.com/advisories/cve-2025-32428 (revision 5, source checked 28 Oct 2026, 06:05 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: jupyter-remote-desktop-proxy 3.0.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI jupyter-remote-desktop-proxy: affected >= 3.0.0, < 3.0.1; fixed in 3.0.1

## Suggested inspection (read-only)
- `python -m pip show jupyter-remote-desktop-proxy`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on jupyter-remote-desktop-proxy.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-vrq4-9hc3-cgp7 (OSV record GHSA-vrq4-9hc3-cgp7 lists affected ranges: PyPI jupyter-remote-desktop-proxy >=3.0.0 <3.0.1 (fixed))
- Verified: https://github.com/advisories/GHSA-vrq4-9hc3-cgp7 (GitHub-reviewed advisory GHSA-vrq4-9hc3-cgp7 lists affected ranges: PyPI jupyter-remote-desktop-proxy >=3.0.0 <=3.0.0)

Commands are suggestions: review each one before running it.

Loading voting…