Skip to content

← Public intelligence

PyPI package

jupyter-lsp

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.3PyPIAmendedPublished

    Unsecured endpoints in the jupyter-lsp server extension

    CVE-2024-22415 · GHSA-4qhp-652w-c22x

    Affected
    • PyPI jupyter-lsp <= 2.2.1
    Fixed in
    2.2.2· Vendor fix available
    Issue
    Impact Installations of jupyter-lsp running in environments without configured file system access control (on the operating system level), and with jupyter-server instances exposed to non-trusted network are vulnerable to unauthorised access and modification of file system beyond the jupyter root directory. Patches Version 2.2.2 has been patched. Workarounds Users of jupyterlab who do not use jupyterlab-lsp can uninstall jupyter-lsp. Credits We would like to credit Bary Levy, researcher of pillar.security research team, for the discovery and responsible disclosure of this vulnerability. Edit: based on advice from pillar.security the Confidentiality/Integrity/Availability were increased to High to reflect potential for critical impact on publicly hosted jupyter-server instances lacking isolation of user privileges on operating system level (for best practices please consult https://jupyterhub.readthedocs.io/en/stable/explanation/websecurity.html#protect-users-from-each-other) and…

    Recommended action: Upgrade to 2.2.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →