Unsecured endpoints in the jupyter-lsp server extension
CVE-2024-22415GHSA-4qhp-652w-c22x
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (jupyter-lsp 2.2.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI jupyter-lsp
- Affected
- <= 2.2.1
- Fixed in
- 2.2.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-4qhp-652w-c22x lists affected ranges: PyPI jupyter-lsp >=0 <2.2.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4qhp-652w-c22x lists affected ranges: PyPI jupyter-lsp >=0 <=2.2.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
- EPSS
- CVE-2024-22415: 0.49% estimated exploitation activity in the next 30 days; percentile 42.28 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Installations of jupyter-lsp running in environments without configured file system access control (on the operating system level), and with jupyter-server instances exposed to non-trusted network are vulnerable to unauthorised access and modification of file system beyond the jupyter root directory. Patches Version 2.2.2 has been patched. Workarounds Users of jupyterlab who do not use jupyterlab-lsp can uninstall jupyter-lsp. Credits We would like to credit Bary Levy, researcher of pillar.security research team, for the discovery and responsible disclosure of this vulnerability. Edit: based on advice from pillar.security the Confidentiality/Integrity/Availability were increased to High to reflect potential for critical impact on publicly hosted jupyter-server instances lacking isolation of user privileges on operating system level (for best practices please consult https://jupyterhub.readthedocs.io/en/stable/explanation/websecurity.html#protect-users-from-each-other) and…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-4qhp-652w-c22x
- Revision 1 · created ·
Published from osv record GHSA-4qhp-652w-c22x
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-22415 Advisory: Unsecured endpoints in the jupyter-lsp server extension IDs: CVE-2024-22415, GHSA-4qhp-652w-c22x Record: https://patchnext.com/advisories/cve-2024-22415 (revision 2, source checked 26 Oct 2026, 13:12 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: jupyter-lsp 2.2.2. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI jupyter-lsp: affected <= 2.2.1; fixed in 2.2.2 ## Suggested inspection (read-only) - `python -m pip show jupyter-lsp`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on jupyter-lsp. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-4qhp-652w-c22x (OSV record GHSA-4qhp-652w-c22x lists affected ranges: PyPI jupyter-lsp >=0 <2.2.2 (fixed)) - Verified: https://github.com/advisories/GHSA-4qhp-652w-c22x (GitHub-reviewed advisory GHSA-4qhp-652w-c22x lists affected ranges: PyPI jupyter-lsp >=0 <=2.2.1) Commands are suggestions: review each one before running it.
Loading voting…