Skip to content

← Public intelligence

PyPI package

ipython

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

8 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Low, CVSS 2.0PyPIAmendedPublished

    IPython vulnerable to command injection via set_term_title

    CVE-2023-24816 · GHSA-29gw-9793-fvw7

    Affected
    • PyPI ipython < 8.10.0
    Fixed in
    8.10.0· Vendor fix available
    Issue
    IPython provides an interactive Python shell and Jupyter kernel to use Python interactively. Versions prior to 8.10.0 are vulnerable to command injection in the settermtitle function under specific conditions. This has been patched in version 8.10.0. Impact Users are only vulnerable when calling this function in Windows in a Python environment where ctypes is not available. The dependency on ctypes in IPython.utils.processwin32 prevents the vulnerable code from ever being reached (making it effectively dead code). However, as a library that could be used by another tool, settermtitle could introduce a vulnerability for dependencies. Currently settermtitle is only called with (semi-)trusted input that contain the current working directory of the current IPython session. If an attacker can control directory names, and manage to get a user to cd into this directory, then the attacker can execute arbitrary commands contained in the folder names.

    Recommended action: Upgrade to 8.10.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. Critical, CVSS 9.3PyPIAmendedPublished

    Improper Input Validation in Jupyter Notebook

    CVE-2015-7337 · GHSA-92mr-v722-f48m

    Affected
    • PyPI ipython <= 3.2.1
    Fixed in
    3.2.2· Vendor fix available
    Issue
    The editor in IPython Notebook before 3.2.2 and Jupyter Notebook 4.0.x before 4.0.5 allows remote attackers to execute arbitrary JavaScript code via a crafted file, which triggers a redirect to files/, related to MIME types.

    Recommended action: Upgrade to 3.2.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  3. Medium, CVSS 5.3PyPIAmendedPublished

    Improper Neutralization of Input During Web Page Generation in IPython

    CVE-2015-4706 · GHSA-q326-jhw3-699g

    Affected
    • PyPI ipython >= 3.0.0, < 3.2.0
    Fixed in
    3.2.0· Vendor fix available
    Issue
    Cross-site scripting (XSS) vulnerability in IPython 3.x before 3.2 allows remote attackers to inject arbitrary web script or HTML via vectors involving JSON error messages and the /api/contents path.

    Recommended action: Upgrade to 3.2.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  4. High, CVSS 8.6PyPIAmendedPublished

    IPython vulnerable to cross site request forgery (CSRF)

    CVE-2015-5607 · GHSA-7fc2-rm35-2pp7

    Affected
    • PyPI ipython >= 0.12, < 2.4.1; >= 3.0.0, < 3.2.3
    Fixed in
    2.4.13.2.3· Vendor fix available
    Issue
    IPython (Interactive Python) is a command shell. Cross-site request forgery in the REST API is possible in in IPython 2 and 3. Versions 2.4.1 and 3.2.3 contain patches.

    Recommended action: Upgrade to 3.2.3 or 2.4.1 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  5. High, CVSS 8.1PyPIAmendedPublished

    IPython Notebook vulnerable to improper validation of the origin of websocket requests

    CVE-2014-3429 · GHSA-75cw-5cgv-g853

    Affected
    • PyPI ipython >= 0.12, < 1.2.0
    Fixed in
    1.2.0· Vendor fix available
    Issue
    IPython Notebook 0.12 through 1.x before 1.2.0 does not validate the origin of websocket requests, which allows remote attackers to execute arbitrary code by leveraging knowledge of the kernel id and a crafted page.

    Recommended action: Upgrade to 1.2.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  6. Medium, CVSS 5.3PyPIAmendedPublished

    Improper Neutralization of Input During Web Page Generation in Jupyter Notebook

    CVE-2015-6938 · GHSA-4vwq-x64q-j4cj

    Affected
    • PyPI ipython <= 3.2.1
    Fixed in
    3.2.2· Vendor fix available
    Issue
    Cross-site scripting (XSS) vulnerability in the file browser in notebook/notebookapp.py in IPython Notebook before 3.2.2 and Jupyter Notebook 4.0.x before 4.0.5 allows remote attackers to inject arbitrary web script or HTML via a folder name. NOTE: this was originally reported as a cross-site request forgery (CSRF) vulnerability, but this may be inaccurate.

    Recommended action: Upgrade to 3.2.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  7. Medium, CVSS 5.3PyPIAmendedPublished

    Improper Neutralization of Input During Web Page Generation in IPython

    CVE-2015-4707 · GHSA-66gw-5xpf-gfp5

    Affected
    • PyPI ipython < 3.2.0
    Fixed in
    3.2.0· Vendor fix available
    Issue
    Cross-site scripting (XSS) vulnerability in IPython before 3.2 allows remote attackers to inject arbitrary web script or HTML via vectors involving JSON error messages and the /api/notebooks path.

    Recommended action: Upgrade to 3.2.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  8. High, CVSS 8.5PyPIAmendedPublished

    Execution with Unnecessary Privileges in ipython

    CVE-2022-21699 · GHSA-pq7m-3gw7-gq5x

    Affected
    • PyPI ipython < 5.11; >= 6.0.0, < 7.16.3; >= 7.17.0, < 7.31.1; >= 8.0.0, < 8.0.1
    Fixed in
    7.16.35.117.31.18.0.1· Vendor fix available
    Issue
    We’d like to disclose an arbitrary code execution vulnerability in IPython that stems from IPython executing untrusted files in CWD. This vulnerability allows one user to run code as another. Proof of concept User1: User2: User2 will see: Patched release and documentation See https://ipython.readthedocs.io/en/stable/whatsnew/version8.html#ipython-8-0-1-cve-2022-21699, Version 8.0.1, 7.31.1 for current Python version are recommended. Version 7.16.3 has also been published for Python 3.6 users, Version 5.11 (source only, 5.x branch on github) for older Python versions.

    Recommended action: Upgrade to 8.0.1, 7.31.1, 7.16.3 or 5.11 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →