Skip to content

← Actionable
Critical, CVSS 9.3amended

Improper Input Validation in Jupyter Notebook

CVE-2015-7337GHSA-92mr-v722-f48m

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (ipython 3.2.2; notebook 4.0.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI ipython

    Affected
    <= 3.2.1
    Fixed in
    3.2.2
  • PyPI notebook

    Affected
    >= 4.0.0, <= 4.0.4
    Fixed in
    4.0.5

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2015-7337: 2.49% estimated exploitation activity in the next 30 days; percentile 84.65 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The editor in IPython Notebook before 3.2.2 and Jupyter Notebook 4.0.x before 4.0.5 allows remote attackers to execute arbitrary JavaScript code via a crafted file, which triggers a redirect to files/, related to MIME types.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-92mr-v722-f48m

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-92mr-v722-f48m

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2015-7337

Advisory: Improper Input Validation in Jupyter Notebook
IDs: CVE-2015-7337, GHSA-92mr-v722-f48m
Record: https://patchnext.com/advisories/cve-2015-7337 (revision 3, source checked 26 Oct 2026, 13:17 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: ipython 3.2.2; notebook 4.0.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI ipython: affected <= 3.2.1; fixed in 3.2.2
- PyPI notebook: affected >= 4.0.0, <= 4.0.4; fixed in 4.0.5

## Suggested inspection (read-only)
- `python -m pip show ipython`: prints the installed version. Run with the environment that serves production active.
- `python -m pip show notebook`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on ipython, notebook.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-92mr-v722-f48m (OSV record GHSA-92mr-v722-f48m lists affected ranges: PyPI notebook >=4.0.0 =0 <3.2.2 (fixed))
- Verified: https://github.com/advisories/GHSA-92mr-v722-f48m (GitHub-reviewed advisory GHSA-92mr-v722-f48m lists affected ranges: PyPI notebook >=4.0.0 =0 <=3.2.1)

Commands are suggestions: review each one before running it.

Loading voting…