Skip to content

← Public intelligence

PyPI package

ipsilon

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

3 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. UnratedPyPIPublished

    Ipsilon denial of service via a duplicate SP name

    CVE-2015-5217 · GHSA-6875-ff47-r6p6

    Affected
    • PyPI ipsilon >= 0.1.0, < 1.2.0
    Fixed in
    1.2.0· Vendor fix available
    Issue
    providers/saml2/admin.py in the Identity Provider (IdP) server in Ipsilon 0.1.0 before 1.0.1 does not properly check permissions to update the SAML2 Service Provider (SP) owner, which allows remote authenticated users to cause a denial of service via a duplicate SP name.

    Recommended action: Upgrade to 1.2.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.devSource checked Evidence →
  2. UnratedPyPIPublished

    Ipsilon denial of service by deleting a SAML2 Service Provider (SP)

    CVE-2015-5301 · GHSA-9qp4-79q8-58pr

    Affected
    • PyPI ipsilon >= 0.1.0, < 1.0.2; >= 1.1.0, < 1.2.0
    Fixed in
    1.0.21.2.0· Vendor fix available
    Issue
    providers/saml2/admin.py in the Identity Provider (IdP) server in Ipsilon 0.1.0 before 1.0.2 and 1.1.x before 1.1.1 does not properly check permissions, which allows remote authenticated users to cause a denial of service by deleting a SAML2 Service Provider (SP).

    Recommended action: Upgrade to 1.2.0 or 1.0.2 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.devSource checked Evidence →
  3. Critical, CVSS 9.1PyPIAmendedPublished

    Session Fixation in ipsilon

    CVE-2016-8638 · GHSA-376m-3rm2-9jm6

    Affected
    • PyPI ipsilon >= 2.0.0, < 2.0.2; >= 1.2.0, < 1.2.1; >= 1.1.0, < 1.1.2; >= 1.0.0, < 1.0.3
    Fixed in
    1.1.22.0.21.0.31.2.1· Vendor fix available
    Issue
    A vulnerability in ipsilon 2.0 before 2.0.2, 1.2 before 1.2.1, 1.1 before 1.1.2, and 1.0 before 1.0.3 was found that allows attacker to log out active sessions of other users. This issue is related to how it tracks sessions, and allows an unauthenticated attacker to view and terminate active sessions from other users. It is also called a "SAML2 multi-session vulnerability."

    Recommended action: Upgrade to 2.0.2, 1.2.1, 1.1.2 or 1.0.3 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →