Ipsilon denial of service via a duplicate SP name
CVE-2015-5217GHSA-6875-ff47-r6p6
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (ipsilon 1.2.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI ipsilon
- Affected
- >= 0.1.0, < 1.2.0
- Fixed in
- 1.2.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-6875-ff47-r6p6 lists affected ranges: PyPI ipsilon >=0.1.0 <1.2.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2015-5217: 1.31% estimated exploitation activity in the next 30 days; percentile 70.69 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
providers/saml2/admin.py in the Identity Provider (IdP) server in Ipsilon 0.1.0 before 1.0.1 does not properly check permissions to update the SAML2 Service Provider (SP) owner, which allows remote authenticated users to cause a denial of service via a duplicate SP name.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from osv record GHSA-6875-ff47-r6p6
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2015-5217 Advisory: Ipsilon denial of service via a duplicate SP name IDs: CVE-2015-5217, GHSA-6875-ff47-r6p6 Record: https://patchnext.com/advisories/cve-2015-5217 (revision 1, source checked 24 Oct 2026, 04:13 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: ipsilon 1.2.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI ipsilon: affected >= 0.1.0, < 1.2.0; fixed in 1.2.0 ## Suggested inspection (read-only) - `python -m pip show ipsilon`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on ipsilon. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-6875-ff47-r6p6 (OSV record GHSA-6875-ff47-r6p6 lists affected ranges: PyPI ipsilon >=0.1.0 <1.2.0 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…