Skip to content

← Public intelligence

PyPI package

invokeai

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

3 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Critical, CVSS 9.3PyPIAmendedPublished

    InvokeAI has External Control of File Name or Path

    CVE-2025-6237 · GHSA-vv9c-xxg7-wmv7

    Affected
    • PyPI invokeai < 6.7.0
    Fixed in
    6.7.0· Vendor fix available
    Issue
    Path Traversal Vulnerability in InvokeAI A path traversal vulnerability in InvokeAI (versions < 6.7.0) allows an unauthenticated remote attacker to read files outside the intended media directory via the bulk downloads API. The endpoint accepts a user-controlled file/item name and concatenates it into a filesystem path without proper canonicalization or allow-listing. By supplying sequences such as `../` (or absolute paths), an attacker can cause the server to traverse directories and return arbitrary files. In certain storage or back-end configurations, abusing attacker-controlled paths can also lead to unintended overwriting or deletion of files referenced by the crafted path. The issue is fixed in 6.7.0, which normalizes and validates input paths and rejects traversal attempts. Affected versions: `< 6.7.0` Patched version: `6.7.0`

    Recommended action: Upgrade to 6.7.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. Critical, CVSS 9.8PyPIAmendedPublished

    InvokeAI Deserialization of Untrusted Data vulnerability

    CVE-2024-12029 · GHSA-mcrp-whpw-jp68

    Affected
    • PyPI invokeai >= 5.3.1, < 5.4.3rc2
    Fixed in
    5.4.3rc2· Vendor fix available
    Issue
    A remote code execution vulnerability exists in invoke-ai/invokeai versions 5.3.1 through 5.4.2 via the /api/v2/models/install API. The vulnerability arises from unsafe deserialization of model files using torch.load without proper validation. Attackers can exploit this by embedding malicious code in model files, which is executed upon loading. This issue is fixed in version 5.4.3rc2.

    Recommended action: Upgrade to 5.4.3rc2 (pre-release) or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  3. Critical, CVSS 9.1PyPIAmendedPublished

    InvokeAI Arbitrary File Deletion vulnerability

    CVE-2024-11042 · GHSA-227r-w5j2-6243

    Affected
    • PyPI invokeai < 5.3.0rc1
    Fixed in
    5.3.0rc1· Vendor fix available
    Issue
    In invoke-ai/invokeai version v5.0.2, the web API `POST /api/v1/images/delete` is vulnerable to Arbitrary File Deletion. This vulnerability allows unauthorized attackers to delete arbitrary files on the server, potentially including critical or sensitive system files such as SSH keys, SQLite databases, and configuration files. This can impact the integrity and availability of applications relying on these files.

    Recommended action: Upgrade to 5.3.0rc1 (pre-release) or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →