InvokeAI has External Control of File Name or Path
CVE-2025-6237GHSA-vv9c-xxg7-wmv7
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (invokeai 6.7.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI invokeai
- Affected
- < 6.7.0
- Fixed in
- 6.7.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-vv9c-xxg7-wmv7 lists affected ranges: PyPI invokeai >=0 <6.7.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-vv9c-xxg7-wmv7 lists affected ranges: PyPI invokeai >=0 <6.7.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 9.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2025-6237: 0.40% estimated exploitation activity in the next 30 days; percentile 34.33 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Path Traversal Vulnerability in InvokeAI A path traversal vulnerability in InvokeAI (versions < 6.7.0) allows an unauthenticated remote attacker to read files outside the intended media directory via the bulk downloads API. The endpoint accepts a user-controlled file/item name and concatenates it into a filesystem path without proper canonicalization or allow-listing. By supplying sequences such as `../` (or absolute paths), an attacker can cause the server to traverse directories and return arbitrary files. In certain storage or back-end configurations, abusing attacker-controlled paths can also lead to unintended overwriting or deletion of files referenced by the crafted path. The issue is fixed in 6.7.0, which normalizes and validates input paths and rejects traversal attempts. Affected versions: `< 6.7.0` Patched version: `6.7.0`
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 5 · amended ·
Amended from osv record GHSA-vv9c-xxg7-wmv7
- Revision 4 · amended ·
Amended from ghsa record GHSA-vv9c-xxg7-wmv7
- Revision 3 · amended ·
Amended from ghsa record GHSA-vv9c-xxg7-wmv7
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-vv9c-xxg7-wmv7
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-6237 Advisory: InvokeAI has External Control of File Name or Path IDs: CVE-2025-6237, GHSA-vv9c-xxg7-wmv7 Record: https://patchnext.com/advisories/cve-2025-6237 (revision 5, source checked 28 Oct 2026, 06:05 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: invokeai 6.7.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI invokeai: affected < 6.7.0; fixed in 6.7.0 ## Suggested inspection (read-only) - `python -m pip show invokeai`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on invokeai. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-vv9c-xxg7-wmv7 (OSV record GHSA-vv9c-xxg7-wmv7 lists affected ranges: PyPI invokeai >=0 <6.7.0 (fixed)) - Verified: https://github.com/advisories/GHSA-vv9c-xxg7-wmv7 (GitHub-reviewed advisory GHSA-vv9c-xxg7-wmv7 lists affected ranges: PyPI invokeai >=0 <6.7.0) Commands are suggestions: review each one before running it.
Loading voting…