Medium, CVSS 5.1PyPIAmendedPublished
Cross-site scripting invenio-records
CVE-2019-1020003 · GHSA-vxh3-mvv7-265j
- Affected
- PyPI invenio-records < 1.0.2; >= 1.1.0, <= 1.1.0; >= 1.2.0, < 1.2.2
- Fixed in
- 1.2.21.0.21.1.1· Vendor fix available
- Issue
- Cross-Site Scripting (XSS) vulnerability in administration interface Impact A Cross-Site Scripting (XSS) vulnerability was discovered when rendering JSON for a record in the administration interface. The vulnerability could be exploited by e.g. a user who had access to upload a new record, that an admin user would then later view in the admin interface. Patches All supported versions of Invenio-Records have been patched. You should upgrade to either v1.0.1, v1.1.1 or v1.2.2 For more information If you have any questions or comments about this advisory: Email us at info@inveniosoftware.org
Recommended action: Upgrade to 1.2.2, 1.1.1 or 1.0.2 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.