Cross-site scripting invenio-records
CVE-2019-1020003GHSA-vxh3-mvv7-265j
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (invenio-records 1.2.2, 1.1.1, 1.0.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI invenio-records
- Affected
- < 1.0.2>= 1.1.0, <= 1.1.0>= 1.2.0, < 1.2.2
- Fixed in
- 1.2.2, 1.0.2, 1.1.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-vxh3-mvv7-265j lists affected ranges: PyPI invenio-records >=0 =1.1.0 =1.2.0 <1.2.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-vxh3-mvv7-265j lists affected ranges: PyPI invenio-records >=0 =1.1.0 =1.2.0 <1.2.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N · score source
- EPSS
- CVE-2019-1020003: 0.66% estimated exploitation activity in the next 30 days; percentile 51.84 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Cross-Site Scripting (XSS) vulnerability in administration interface Impact A Cross-Site Scripting (XSS) vulnerability was discovered when rendering JSON for a record in the administration interface. The vulnerability could be exploited by e.g. a user who had access to upload a new record, that an admin user would then later view in the admin interface. Patches All supported versions of Invenio-Records have been patched. You should upgrade to either v1.0.1, v1.1.1 or v1.2.2 For more information If you have any questions or comments about this advisory: Email us at info@inveniosoftware.org
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-vxh3-mvv7-265j
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-vxh3-mvv7-265j
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2019-1020003 Advisory: Cross-site scripting invenio-records IDs: CVE-2019-1020003, GHSA-vxh3-mvv7-265j Record: https://patchnext.com/advisories/cve-2019-1020003 (revision 3, source checked 26 Oct 2026, 13:17 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: invenio-records 1.2.2, 1.1.1, 1.0.2. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI invenio-records: affected < 1.0.2; >= 1.1.0, <= 1.1.0; >= 1.2.0, < 1.2.2; fixed in 1.2.2, 1.0.2, 1.1.1 ## Suggested inspection (read-only) - `python -m pip show invenio-records`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on invenio-records. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-vxh3-mvv7-265j (OSV record GHSA-vxh3-mvv7-265j lists affected ranges: PyPI invenio-records >=0 =1.1.0 =1.2.0 <1.2.2 (fixed)) - Verified: https://github.com/advisories/GHSA-vxh3-mvv7-265j (GitHub-reviewed advisory GHSA-vxh3-mvv7-265j lists affected ranges: PyPI invenio-records >=0 =1.1.0 =1.2.0 <1.2.2) Commands are suggestions: review each one before running it.
Loading voting…