Skip to content

← Public intelligence

PyPI package

invenio-communities

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 6.3PyPIAmendedPublished

    Invenio-Communities has a Cross-Site Scripting (XSS) vulnerability in React components

    GHSA-hjx6-f647-mvf9

    Affected
    • PyPI invenio-communities >= 5.0.0, < 7.8.0; >= 3.0.0, < 4.2.2; < 2.8.11
    Fixed in
    4.2.27.8.02.8.11· Vendor fix available
    Issue
    Impact We have identified a Cross-Site Scripting (XSS) vulnerability within certain React components related to community members in the Invenio-Communities module. This vulnerability enables a user to inject a script tag into the Affiliations field during the account registration process. The malicious script is executed when the user creates a new community and is listed as a public member. The script is triggered whenever any user visits the Members section of any community that includes the compromised user. This can potentially allow the attacker to access personal information, such as cookies, of the visiting user. Patches The problem has been patched in v7.8.0. Patches also have been backported in versions v4.2.2 and v2.8.11. Credits Thanks to Twitter.com/AliGoodLuck11 for reporting the vulnerability with a detailed description on how to reproduce it! For more information If you have any questions or comments about this advisory: Email us at info@inveniosoftware.org

    Recommended action: Upgrade to 7.8.0, 4.2.2 or 2.8.11 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. Medium, CVSS 5.1PyPIAmendedPublished

    Cross-site Scripting in invenio-communities

    CVE-2019-1020005 · GHSA-mfv8-q39f-mgfg

    Affected
    • PyPI invenio-communities <= 1.0.0a19
    Fixed in
    1.0.0a20· Vendor fix available
    Issue
    Cross-Site Scripting (XSS) vulnerability in Jinja templates Impact A Cross-Site Scripting (XSS) vulnerability was discovered in two Jinja templates in the Invenio-Communities module. The vulnerability allows a user to create a new community and include script element tags inside the description and page fields. Patches The problem has been patched in v1.0.0a20. For more information If you have any questions or comments about this advisory: Email us at info@inveniosoftware.org

    Recommended action: Upgrade to 1.0.0a20 (pre-release) or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →