Invenio-Communities has a Cross-Site Scripting (XSS) vulnerability in React components
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (invenio-communities 7.8.0, 4.2.2, 2.8.11), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI invenio-communities
- Affected
- >= 5.0.0, < 7.8.0>= 3.0.0, < 4.2.2< 2.8.11
- Fixed in
- 4.2.2, 7.8.0, 2.8.11
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-hjx6-f647-mvf9 lists affected ranges: PyPI invenio-communities >=5.0.0 =3.0.0 =0 <2.8.11 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-hjx6-f647-mvf9 lists affected ranges: PyPI invenio-communities >=5.0.0 =3.0.0 =0 <2.8.11
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Impact We have identified a Cross-Site Scripting (XSS) vulnerability within certain React components related to community members in the Invenio-Communities module. This vulnerability enables a user to inject a script tag into the Affiliations field during the account registration process. The malicious script is executed when the user creates a new community and is listed as a public member. The script is triggered whenever any user visits the Members section of any community that includes the compromised user. This can potentially allow the attacker to access personal information, such as cookies, of the visiting user. Patches The problem has been patched in v7.8.0. Patches also have been backported in versions v4.2.2 and v2.8.11. Credits Thanks to Twitter.com/AliGoodLuck11 for reporting the vulnerability with a detailed description on how to reproduce it! For more information If you have any questions or comments about this advisory: Email us at info@inveniosoftware.org
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-hjx6-f647-mvf9
- Revision 1 · created ·
Published from osv record GHSA-hjx6-f647-mvf9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-hjx6-f647-mvf9 Advisory: Invenio-Communities has a Cross-Site Scripting (XSS) vulnerability in React components IDs: GHSA-hjx6-f647-mvf9 Record: https://patchnext.com/advisories/ghsa-hjx6-f647-mvf9 (revision 2, source checked 26 Oct 2026, 13:16 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: invenio-communities 7.8.0, 4.2.2, 2.8.11. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI invenio-communities: affected >= 5.0.0, < 7.8.0; >= 3.0.0, < 4.2.2; < 2.8.11; fixed in 4.2.2, 7.8.0, 2.8.11 ## Suggested inspection (read-only) - `python -m pip show invenio-communities`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on invenio-communities. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-hjx6-f647-mvf9 (OSV record GHSA-hjx6-f647-mvf9 lists affected ranges: PyPI invenio-communities >=5.0.0 =3.0.0 =0 <2.8.11 (fixed)) - Verified: https://github.com/advisories/GHSA-hjx6-f647-mvf9 (GitHub-reviewed advisory GHSA-hjx6-f647-mvf9 lists affected ranges: PyPI invenio-communities >=5.0.0 =3.0.0 =0 <2.8.11) Commands are suggestions: review each one before running it.
Loading voting…