Skip to content

← Public intelligence

PyPI package

html5lib

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 5.3PyPIAmendedPublished

    Improper Neutralization of Input During Web Page Generation in html5lib

    CVE-2016-9909 · GHSA-v9v9-xffq-rwr4

    Affected
    • PyPI html5lib < 0.999999999
    Fixed in
    0.999999999· Vendor fix available
    Issue
    The serializer in html5lib before 0.99999999 might allow remote attackers to conduct cross-site scripting (XSS) attacks by leveraging mishandling of the < (less than) character in attribute values.

    Recommended action: Upgrade to 0.999999999 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. Medium, CVSS 5.3PyPIAmendedPublished

    Cross-site Scripting in html5lib

    CVE-2016-9910 · GHSA-8f6m-gfq9-g33v

    Affected
    • PyPI html5lib < 0.99999999
    Fixed in
    0.99999999· Vendor fix available
    Issue
    The serializer in html5lib before 0.99999999 might allow remote attackers to conduct cross-site scripting (XSS) attacks by leveraging mishandling of special characters in attribute values, a different vulnerability than CVE-2016-9909.

    Recommended action: Upgrade to 0.99999999 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →