Cross-site Scripting in html5lib
CVE-2016-9910GHSA-8f6m-gfq9-g33v
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (html5lib 0.99999999), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI html5lib
- Affected
- < 0.99999999
- Fixed in
- 0.99999999
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-8f6m-gfq9-g33v lists affected ranges: PyPI html5lib >=0 <0.99999999 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-8f6m-gfq9-g33v lists affected ranges: PyPI html5lib >=0 <0.99999999
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N · score source
- EPSS
- CVE-2016-9910: 2.16% estimated exploitation activity in the next 30 days; percentile 82.23 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The serializer in html5lib before 0.99999999 might allow remote attackers to conduct cross-site scripting (XSS) attacks by leveraging mishandling of special characters in attribute values, a different vulnerability than CVE-2016-9909.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-8f6m-gfq9-g33v
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-8f6m-gfq9-g33v
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2016-9910 Advisory: Cross-site Scripting in html5lib IDs: CVE-2016-9910, GHSA-8f6m-gfq9-g33v Record: https://patchnext.com/advisories/cve-2016-9910 (revision 3, source checked 26 Oct 2026, 13:17 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: html5lib 0.99999999. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI html5lib: affected < 0.99999999; fixed in 0.99999999 ## Suggested inspection (read-only) - `python -m pip show html5lib`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on html5lib. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-8f6m-gfq9-g33v (OSV record GHSA-8f6m-gfq9-g33v lists affected ranges: PyPI html5lib >=0 <0.99999999 (fixed)) - Verified: https://github.com/advisories/GHSA-8f6m-gfq9-g33v (GitHub-reviewed advisory GHSA-8f6m-gfq9-g33v lists affected ranges: PyPI html5lib >=0 <0.99999999) Commands are suggestions: review each one before running it.
Loading voting…