Skip to content

← Public intelligence

PyPI package

hermes-agent

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

8 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 8.7PyPIAmendedPublished

    Hermes Agent contains a DNS rebinding vulnerability in WebSocket endpoints that allows remote attackers to bypass Host and Origin validation

    CVE-2026-53869 · GHSA-4pqm-j46f-795x

    Affected
    • PyPI hermes-agent < 0.16.0
    Fixed in
    0.16.0· Vendor fix available
    Issue
    Hermes Agent before 0.16.0 contains a DNS rebinding vulnerability in WebSocket endpoints that allows remote attackers to bypass Host and Origin validation. FastAPI HTTP middleware does not execute for WebSocket upgrade requests on /api/pty, /api/ws, /api/pub, and /api/events endpoints, enabling attackers to exploit DNS rebinding and inject malicious commands or read terminal output.

    Recommended action: Upgrade to 0.16.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. Medium, CVSS 6.8PyPIAmendedPublished

    Hermes Agent creates response_store.db and webhook_subscriptions.json with world-readable permissions (mode 0o644)

    CVE-2026-53870 · GHSA-99f9-j8r3-p853

    Affected
    • PyPI hermes-agent < 0.16.0
    Fixed in
    0.16.0· Vendor fix available
    Issue
    Hermes Agent before 0.16.0 creates responsestore.db and webhooksubscriptions.json with world-readable permissions (mode 0o644), exposing conversation history and HMAC secrets to local users. Attackers with local filesystem access can read these files directly to obtain sensitive data including conversation history, tool payloads, prompts, and per-route HMAC secrets.

    Recommended action: Upgrade to 0.16.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  3. Low, CVSS 2.1PyPIAmendedPublished

    hermes-agent has an Injection issue

    CVE-2026-10223 · GHSA-33qv-c5qm-799v

    Affected
    • PyPI hermes-agent < 0.15.0
    Fixed in
    0.15.0· Vendor fix available
    Issue
    A weakness has been identified in NousResearch hermes-agent up to 2026.4.30. This affects the function scanmemorycontent of the file tools/memorytool.py. This manipulation causes injection. The attack can be initiated remotely. The exploit has been made available to the public and could be used for attacks. The vendor was contacted early about this disclosure but did not respond in any way.

    Recommended action: Upgrade to 0.15.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  4. Low, CVSS 2.9PyPIAmendedPublished

    hermes-agent has an Injection issue

    CVE-2026-10222 · GHSA-mv8x-fg99-32mf

    Affected
    • PyPI hermes-agent < 0.18.0
    Fixed in
    0.18.0· Vendor fix available
    Issue
    A security flaw has been discovered in NousResearch hermes-agent up to 2026.4.30. Affected by this issue is the function sanitizeenvlines of the file hermescli/config.py. The manipulation results in injection. It is possible to launch the attack remotely. The attack requires a high level of complexity. The exploitation is known to be difficult. The exploit has been released to the public and may be used for attacks. The vendor was contacted early about this disclosure but did not respond in any way.

    Recommended action: Upgrade to 0.18.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  5. Low, CVSS 1.9PyPIAmendedPublished

    hermes-agent has an Incorrect Comparison

    CVE-2026-9369 · GHSA-cv5c-mh6j-wvp9

    Affected
    • PyPI hermes-agent < 0.15.0
    Fixed in
    0.15.0· Vendor fix available
    Issue
    A security flaw has been discovered in NousResearch hermes-agent 2026.4.23. Affected is the function discoverdashboardplugins of the file hermescli/webserver.py of the component CLI web-dashboard Interface. Performing a manipulation of the argument HERMESENABLEPROJECTPLUGINS results in incorrect comparison. The attack is only possible with local access. The exploit has been released to the public and may be used for attacks. The vendor was contacted early about this disclosure but did not respond in any way.

    Recommended action: Upgrade to 0.15.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  6. Medium, CVSS 5.5PyPIAmendedPublished

    hermes-agent has a sandbox issue

    CVE-2026-9368 · GHSA-wm96-9gfh-vvgq

    Affected
    • PyPI hermes-agent < 0.11.0
    Fixed in
    0.11.0· Vendor fix available
    Issue
    A vulnerability was identified in NousResearch hermes-agent up to 2026.4.16. This impacts the function executecode of the file tools/codeexecutiontool.py of the component Environment Variable Handler. Such manipulation leads to sandbox issue. It is possible to launch the attack remotely. The exploit is publicly available and might be used. The vendor was contacted early about this disclosure but did not respond in any way.

    Recommended action: Upgrade to 0.11.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  7. Medium, CVSS 5.5PyPIAmendedPublished

    hermes-agent has an Injection issue

    CVE-2026-9366 · GHSA-pgp4-xr4j-h5cg

    Affected
    • PyPI hermes-agent < 0.15.0
    Fixed in
    0.15.0· Vendor fix available
    Issue
    A vulnerability was found in NousResearch hermes-agent 2026.4.23. The impacted element is the function scancontextcontent of the file agent/promptbuilder.py. The manipulation results in injection. The attack may be performed from remote. The exploit has been made public and could be used. The vendor was contacted early about this disclosure but did not respond in any way.

    Recommended action: Upgrade to 0.15.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  8. Medium, CVSS 5.5PyPIAmendedPublished

    hermes-agent has an Injection issue

    CVE-2026-9353 · GHSA-238w-f66p-w349

    Affected
    • PyPI hermes-agent < 0.15.0
    Fixed in
    0.15.0· Vendor fix available
    Issue
    A security vulnerability has been detected in NousResearch hermes-agent up to 2026.4.23. Impacted is an unknown function of the file agent/skillsguard.py of the component Skills Guard Multi-Word Prompt Handler. The manipulation of the argument THREATPATTERNS leads to injection. Remote exploitation of the attack is possible. The exploit has been disclosed publicly and may be used. The vendor was contacted early about this disclosure but did not respond in any way.

    Recommended action: Upgrade to 0.15.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →