Skip to content

← Actionable
Low, CVSS 1.9amended

hermes-agent has an Incorrect Comparison

CVE-2026-9369GHSA-cv5c-mh6j-wvp9

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (hermes-agent 0.15.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
1.9 · CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P · score source
EPSS
  • CVE-2026-9369: 0.23% estimated exploitation activity in the next 30 days; percentile 13.73 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A security flaw has been discovered in NousResearch hermes-agent 2026.4.23. Affected is the function discoverdashboardplugins of the file hermescli/webserver.py of the component CLI web-dashboard Interface. Performing a manipulation of the argument HERMESENABLEPROJECTPLUGINS results in incorrect comparison. The attack is only possible with local access. The exploit has been released to the public and may be used for attacks. The vendor was contacted early about this disclosure but did not respond in any way.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-cv5c-mh6j-wvp9

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-cv5c-mh6j-wvp9

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-9369

Advisory: hermes-agent has an Incorrect Comparison
IDs: CVE-2026-9369, GHSA-cv5c-mh6j-wvp9
Record: https://patchnext.com/advisories/cve-2026-9369 (revision 3, source checked 26 Oct 2026, 13:46 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 1.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: hermes-agent 0.15.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI hermes-agent: affected < 0.15.0; fixed in 0.15.0

## Suggested inspection (read-only)
- `python -m pip show hermes-agent`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on hermes-agent.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-cv5c-mh6j-wvp9 (OSV record GHSA-cv5c-mh6j-wvp9 lists affected ranges: PyPI hermes-agent >=0 <0.15.0 (fixed))
- Verified: https://github.com/advisories/GHSA-cv5c-mh6j-wvp9 (GitHub-reviewed advisory GHSA-cv5c-mh6j-wvp9 lists affected ranges: PyPI hermes-agent >=0 <0.15.0)

Commands are suggestions: review each one before running it.

Loading voting…