Skip to content

← Public intelligence

PyPI package

graphitedb

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.8PyPIAmendedPublished

    Graphite Has a Pickle Deserialization Vulnerability

    GHSA-qw48-84f6-28gv

    Affected
    • PyPI graphitedb < 0.2
    Fixed in
    0.2· Vendor fix available
    Issue
    Impact Type of vulnerability: Insecure Deserialization via Python's pickle module. Who is impacted: Users of Graphite graph database engine versions before 0.2 who load database files from untrusted or third-party sources. An attacker could craft a malicious database file that executes arbitrary code when loaded by the engine. This is possible because the engine used pickle for serialization, which is known to be unsafe for untrusted data. Patches The vulnerability has been patched starting from version 0.2. All users should upgrade to version 0.2 or later (the current version is 0.4 at publishing time). In version 0.2 and above, the engine uses JSON instead of pickle for database storage, eliminating the deserialization risk. Workarounds If users cannot upgrade immediately: 1. Do not load database files from untrusted or unknown sources when using versions <0.2. 2. Migrate existing pickle-based databases to the new JSON format using the provided migration module: After migration,…

    Recommended action: Upgrade to 0.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →