Graphite Has a Pickle Deserialization Vulnerability
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (graphitedb 0.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI graphitedb
- Affected
- < 0.2
- Fixed in
- 0.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-qw48-84f6-28gv lists affected ranges: PyPI graphitedb >=0 <0.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-qw48-84f6-28gv lists affected ranges: PyPI graphitedb >=0 <0.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.8 · CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Impact Type of vulnerability: Insecure Deserialization via Python's pickle module. Who is impacted: Users of Graphite graph database engine versions before 0.2 who load database files from untrusted or third-party sources. An attacker could craft a malicious database file that executes arbitrary code when loaded by the engine. This is possible because the engine used pickle for serialization, which is known to be unsafe for untrusted data. Patches The vulnerability has been patched starting from version 0.2. All users should upgrade to version 0.2 or later (the current version is 0.4 at publishing time). In version 0.2 and above, the engine uses JSON instead of pickle for database storage, eliminating the deserialization risk. Workarounds If users cannot upgrade immediately: 1. Do not load database files from untrusted or unknown sources when using versions <0.2. 2. Migrate existing pickle-based databases to the new JSON format using the provided migration module: After migration,…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-qw48-84f6-28gv
- Revision 1 · created ·
Published from osv record GHSA-qw48-84f6-28gv
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-qw48-84f6-28gv Advisory: Graphite Has a Pickle Deserialization Vulnerability IDs: GHSA-qw48-84f6-28gv Record: https://patchnext.com/advisories/ghsa-qw48-84f6-28gv (revision 2, source checked 26 Oct 2026, 13:41 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: graphitedb 0.2. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI graphitedb: affected < 0.2; fixed in 0.2 ## Suggested inspection (read-only) - `python -m pip show graphitedb`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on graphitedb. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-qw48-84f6-28gv (OSV record GHSA-qw48-84f6-28gv lists affected ranges: PyPI graphitedb >=0 <0.2 (fixed)) - Verified: https://github.com/advisories/GHSA-qw48-84f6-28gv (GitHub-reviewed advisory GHSA-qw48-84f6-28gv lists affected ranges: PyPI graphitedb >=0 <0.2) Commands are suggestions: review each one before running it.
Loading voting…