Skip to content

← Public intelligence

PyPI package

google-cloud-aiplatform

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 8.6PyPIAmendedPublished

    Google Cloud Vertex AI SDK affected by Stored Cross-Site Scripting (XSS)

    CVE-2026-2472 · GHSA-qv8j-hgpc-vrq8

    Affected
    • PyPI google-cloud-aiplatform >= 1.98.0, < 1.131.0
    Fixed in
    1.131.0· Vendor fix available
    Issue
    Stored Cross-Site Scripting (XSS) in the genai/evalsvisualization component of Google Cloud Vertex AI SDK (google-cloud-aiplatform) versions from 1.98.0 up to (but not including) 1.131.0 allows an unauthenticated remote attacker to execute arbitrary JavaScript in a victim's Jupyter or Colab environment via injecting script escape sequences into model evaluation results or dataset JSON data.

    Recommended action: Upgrade to 1.131.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. High, CVSS 7.7PyPIAmendedPublished

    Google Cloud Vertex AI has a a vulnerability involving predictable bucket naming

    CVE-2026-2473 · GHSA-wh2j-26j7-9728

    Affected
    • PyPI google-cloud-aiplatform >= 1.21.0, < 1.133.0
    Fixed in
    1.133.0· Vendor fix available
    Issue
    Predictable bucket naming in Vertex AI Experiments in Google Cloud Vertex AI from version 1.21.0 up to (but not including) 1.133.0 on Google Cloud Platform allows an unauthenticated remote attacker to achieve cross-tenant remote code execution, model theft, and poisoning via pre-creating predictably named Cloud Storage buckets (Bucket Squatting). This vulnerability was patched and no customer action is needed.

    Recommended action: Upgrade to 1.133.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →