Skip to content

← Actionable
High, CVSS 8.6amended

Google Cloud Vertex AI SDK affected by Stored Cross-Site Scripting (XSS)

CVE-2026-2472GHSA-qv8j-hgpc-vrq8

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (google-cloud-aiplatform 1.131.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.6 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:H/VI:H/VA:H/SC:L/SI:L/SA:L/U:Amber · score source
EPSS
  • CVE-2026-2472: 0.61% estimated exploitation activity in the next 30 days; percentile 49.16 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Stored Cross-Site Scripting (XSS) in the genai/evalsvisualization component of Google Cloud Vertex AI SDK (google-cloud-aiplatform) versions from 1.98.0 up to (but not including) 1.131.0 allows an unauthenticated remote attacker to execute arbitrary JavaScript in a victim's Jupyter or Colab environment via injecting script escape sequences into model evaluation results or dataset JSON data.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-qv8j-hgpc-vrq8

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-qv8j-hgpc-vrq8

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-2472

Advisory: Google Cloud Vertex AI SDK affected by Stored Cross-Site Scripting (XSS)
IDs: CVE-2026-2472, GHSA-qv8j-hgpc-vrq8
Record: https://patchnext.com/advisories/cve-2026-2472 (revision 3, source checked 26 Oct 2026, 13:36 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: google-cloud-aiplatform 1.131.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI google-cloud-aiplatform: affected >= 1.98.0, < 1.131.0; fixed in 1.131.0

## Suggested inspection (read-only)
- `python -m pip show google-cloud-aiplatform`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on google-cloud-aiplatform.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-qv8j-hgpc-vrq8 (OSV record GHSA-qv8j-hgpc-vrq8 lists affected ranges: PyPI google-cloud-aiplatform >=1.98.0 <1.131.0 (fixed))
- Verified: https://github.com/advisories/GHSA-qv8j-hgpc-vrq8 (GitHub-reviewed advisory GHSA-qv8j-hgpc-vrq8 lists affected ranges: PyPI google-cloud-aiplatform >=1.98.0 <1.131.0)

Commands are suggestions: review each one before running it.

Loading voting…