Skip to content

← Public intelligence

PyPI package

frappe

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

4 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 6.6PyPIAmendedPublished

    Frappe has possibility of SQL injection due to improper validations

    CVE-2025-30217 · GHSA-6phg-4wmq-h5h3

    Affected
    • PyPI frappe < 14.93.2; >= 15.0.0, < 15.55.0
    Fixed in
    14.93.215.55.0· Vendor fix available
    Issue
    Impact SQL injection could be achieved via a specially crafted request, which could allow malicious person to gain access to sensitive information. Workarounds Upgrading is required, no other workaround is present.

    Recommended action: Upgrade to 15.55.0 or 14.93.2 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. High, CVSS 8.0PyPIAmendedPublished

    Frappe vulnerable to information disclosure leading to account takeover

    CVE-2025-30214 · GHSA-qrv3-jc3h-f3m6

    Affected
    • PyPI frappe < 14.89.0; >= 15.0.0, < 15.51.0
    Fixed in
    15.51.014.89.0· Vendor fix available
    Issue
    Impact Making crafted requests could lead to information disclosure that could further lead to account takeover. Workarounds There's no workaround to fix this without upgrading. Credits Thanks to Thanh of Calif.io for reporting the issue

    Recommended action: Upgrade to 15.51.0 or 14.89.0 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  3. Medium, CVSS 6.3PyPIAmendedPublished

    Frappe has Possibility of Remote Code Execution due to improper validation

    CVE-2025-30213 · GHSA-v342-4xr9-x3q3

    Affected
    • PyPI frappe < 14.91.0; >= 15.0.0, < 15.52.0
    Fixed in
    14.91.015.52.0· Vendor fix available
    Issue
    Impact A system user was able to create certain documents in a specific way that could lead to RCE. Workarounds There's no workaround, an upgrade is required. Credits Thanks to Thanh of Calif.io for reporting the issue

    Recommended action: Upgrade to 15.52.0 or 14.91.0 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  4. Medium, CVSS 6.6PyPIAmendedPublished

    Frappe has possibility of SQL injection due to improper validations

    CVE-2025-30212 · GHSA-3hj6-r5c9-q8f3

    Affected
    • PyPI frappe < 14.89.0; >= 15.0.0, < 15.51.0
    Fixed in
    15.51.014.89.0· Vendor fix available
    Issue
    Impact An SQL Injection vulnerability has been identified in Frappe Framework which could allow a malicious actor to access sensitive information. Workarounds Upgrading is required, no other workaround is present. Credits Thanks to Thanh of Calif.io for reporting the issue

    Recommended action: Upgrade to 15.51.0 or 14.89.0 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →