Frappe has Possibility of Remote Code Execution due to improper validation
CVE-2025-30213GHSA-v342-4xr9-x3q3
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (frappe 15.52.0, 14.91.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI frappe
- Affected
- < 14.91.0>= 15.0.0, < 15.52.0
- Fixed in
- 14.91.0, 15.52.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-v342-4xr9-x3q3 lists affected ranges: PyPI frappe >=0 =15.0.0 <15.52.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-v342-4xr9-x3q3 lists affected ranges: PyPI frappe >=0 =15.0.0 <15.52.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U · score source
- EPSS
- CVE-2025-30213: 0.72% estimated exploitation activity in the next 30 days; percentile 54.00 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact A system user was able to create certain documents in a specific way that could lead to RCE. Workarounds There's no workaround, an upgrade is required. Credits Thanks to Thanh of Calif.io for reporting the issue
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-v342-4xr9-x3q3
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-v342-4xr9-x3q3
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-30213 Advisory: Frappe has Possibility of Remote Code Execution due to improper validation IDs: CVE-2025-30213, GHSA-v342-4xr9-x3q3 Record: https://patchnext.com/advisories/cve-2025-30213 (revision 3, source checked 26 Oct 2026, 13:31 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: frappe 15.52.0, 14.91.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI frappe: affected < 14.91.0; >= 15.0.0, < 15.52.0; fixed in 14.91.0, 15.52.0 ## Suggested inspection (read-only) - `python -m pip show frappe`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on frappe. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-v342-4xr9-x3q3 (OSV record GHSA-v342-4xr9-x3q3 lists affected ranges: PyPI frappe >=0 =15.0.0 <15.52.0 (fixed)) - Verified: https://github.com/advisories/GHSA-v342-4xr9-x3q3 (GitHub-reviewed advisory GHSA-v342-4xr9-x3q3 lists affected ranges: PyPI frappe >=0 =15.0.0 <15.52.0) Commands are suggestions: review each one before running it.
Loading voting…