Skip to content

← Public intelligence

PyPI package

fava

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

3 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 5.3PyPIAmendedPublished

    Fava vulnerable to reflected cross-site scripting

    CVE-2022-2589 · GHSA-6hcj-qrw3-m66q

    Affected
    • PyPI fava < 1.22.3
    Fixed in
    1.22.3· Vendor fix available
    Issue
    Fava before 1.22.3 is vulnerable to reflected cross-site scripting due to improper validation on filter conversion.

    Recommended action: Upgrade to 1.22.3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. Medium, CVSS 5.3PyPIAmendedPublished

    Fava time and filter parameters vulnerable to reflected Cross-site Scripting

    CVE-2022-2514 · GHSA-xrf4-39fm-j5f2

    Affected
    • PyPI fava < 1.22
    Fixed in
    1.22· Vendor fix available
    Issue
    The time and filter parameters in Fava prior to v1.22 are vulnerable to reflected cross-site scripting due to the lack of escaping of error messages which contained the parameters in verbatim.

    Recommended action: Upgrade to 1.22 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  3. Medium, CVSS 5.3PyPIAmendedPublished

    Fava vulnerable to Reflected Cross-site Scripting

    CVE-2022-2523 · GHSA-q8hg-3vqv-f8v3

    Affected
    • PyPI fava < 1.22.2
    Fixed in
    1.22.2· Vendor fix available
    Issue
    Cross-site Scripting (XSS) - Reflected in GitHub repository beancount/fava prior to 1.22.2. The querystring parameter of Fava is vulnerable to reflected cross-site scripting, for which a attacker can modify any information that the user is able to modify. This issue is fixed in version 1.22.2.

    Recommended action: Upgrade to 1.22.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →