Skip to content

← Actionable
Medium, CVSS 5.3amended

Fava vulnerable to Reflected Cross-site Scripting

CVE-2022-2523GHSA-q8hg-3vqv-f8v3

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (fava 1.22.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI fava

    Affected
    < 1.22.2
    Fixed in
    1.22.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N · score source
EPSS
  • CVE-2022-2523: 0.87% estimated exploitation activity in the next 30 days; percentile 58.77 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Cross-site Scripting (XSS) - Reflected in GitHub repository beancount/fava prior to 1.22.2. The querystring parameter of Fava is vulnerable to reflected cross-site scripting, for which a attacker can modify any information that the user is able to modify. This issue is fixed in version 1.22.2.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-q8hg-3vqv-f8v3

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-q8hg-3vqv-f8v3

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-2523

Advisory: Fava vulnerable to Reflected Cross-site Scripting
IDs: CVE-2022-2523, GHSA-q8hg-3vqv-f8v3
Record: https://patchnext.com/advisories/cve-2022-2523 (revision 3, source checked 26 Oct 2026, 13:17 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: fava 1.22.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI fava: affected < 1.22.2; fixed in 1.22.2

## Suggested inspection (read-only)
- `python -m pip show fava`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on fava.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-q8hg-3vqv-f8v3 (OSV record GHSA-q8hg-3vqv-f8v3 lists affected ranges: PyPI fava >=0 <1.22.2 (fixed))
- Verified: https://github.com/advisories/GHSA-q8hg-3vqv-f8v3 (GitHub-reviewed advisory GHSA-q8hg-3vqv-f8v3 lists affected ranges: PyPI fava >=0 <1.22.2)

Commands are suggestions: review each one before running it.

Loading voting…