Skip to content

← Public intelligence

PyPI package

executorch

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

6 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 8.1PyPIAmendedPublished

    ExecuTorch vulnerable to Heap-based Buffer Overflow attack

    CVE-2025-30402 · GHSA-h952-963h-rv99

    Affected
    • PyPI executorch <= 0.6.0
    Fixed in
    0.7.0· Vendor fix available
    Issue
    A heap-buffer-overflow vulnerability in the loading of ExecuTorch methods can cause the runtime to crash and potentially result in code execution or other undesirable effects. This issue affects ExecuTorch prior to commit 93b1a0c15f7eda49b2bc46b5b4c49557b4e9810f

    Recommended action: Upgrade to 0.7.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. Critical, CVSS 9.8PyPIAmendedPublished

    ExecuTorch integer overflow vulnerability

    CVE-2025-30404 · GHSA-hj95-mhgf-jxc4

    Affected
    • PyPI executorch < 0.7.0
    Fixed in
    0.7.0· Vendor fix available
    Issue
    An integer overflow vulnerability in the loading of ExecuTorch models can cause overlapping allocations, potentially resulting in code execution or other undesirable effects. This issue affects ExecuTorch prior to commit d158236b1dc84539c1b16843bc74054c9dcba006.

    Recommended action: Upgrade to 0.7.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)osv.dev (3)Source checked Evidence →
  3. Critical, CVSS 9.8PyPIAmendedPublished

    ExecuTorch vulnerable to Heap-based Buffer Overflow

    CVE-2025-54951 · GHSA-xc7w-r669-48pf

    Affected
    • PyPI executorch < 0.7.0
    Fixed in
    0.7.0· Vendor fix available
    Issue
    A group of related buffer overflow vulnerabilities in the loading of ExecuTorch models can cause the runtime to crash and potentially result in code execution or other undesirable effects. This issue affects ExecuTorch prior to commit cea9b23aa8ff78aff92829a466da97461cc7930c.

    Recommended action: Upgrade to 0.7.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)osv.dev (3)Source checked Evidence →
  4. Critical, CVSS 9.8PyPIAmendedPublished

    ExecuTorch heap buffer overflow vulnerability

    CVE-2025-54949 · GHSA-9m39-3mf3-xwch

    Affected
    • PyPI executorch < 0.7.0
    Fixed in
    0.7.0· Vendor fix available
    Issue
    A heap buffer overflow vulnerability in the loading of ExecuTorch models can potentially result in code execution or other undesirable effects. This issue affects ExecuTorch prior to commit ede82493dae6d2d43f8c424e7be4721abe5242be

    Recommended action: Upgrade to 0.7.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)osv.dev (3)Source checked Evidence →
  5. Critical, CVSS 9.8PyPIAmendedPublished

    ExecuTorch out-of-bounds access vulnerability

    CVE-2025-54950 · GHSA-f9hx-c6jf-3qxm

    Affected
    • PyPI executorch < 0.7.0
    Fixed in
    0.7.0· Vendor fix available
    Issue
    An out-of-bounds access vulnerability in the loading of ExecuTorch models can cause the runtime to crash and potentially result in code execution or other undesirable effects. This issue affects ExecuTorch prior to commit fb03b6f85596a8f954d97929075335255b6a58d4.

    Recommended action: Upgrade to 0.7.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)osv.dev (3)Source checked Evidence →
  6. Critical, CVSS 9.8PyPIAmendedPublished

    ExecuTorch integer overflow vulnerability

    CVE-2025-30405 · GHSA-84m3-f99p-cqx5

    Affected
    • PyPI executorch < 0.7.0
    Fixed in
    0.7.0· Vendor fix available
    Issue
    An integer overflow vulnerability in the loading of ExecuTorch models can cause objects to be placed outside their allocated memory area, potentially resulting in code execution or other undesirable effects. This issue affects ExecuTorch prior to commit 0830af8207240df8d7f35b984cdf8bc35d74fa73.

    Recommended action: Upgrade to 0.7.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)osv.dev (3)Source checked Evidence →