ExecuTorch integer overflow vulnerability
CVE-2025-30404GHSA-hj95-mhgf-jxc4
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.pytorch:executorch-android 0.7.0; executorch 0.7.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.pytorch:executorch-android
- Affected
- < 0.7.0
- Fixed in
- 0.7.0
PyPI executorch
- Affected
- < 0.7.0
- Fixed in
- 0.7.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record PYSEC-2026-335 lists affected ranges: PyPI executorch >=0 <0.7.0 (fixed)
VerifiedObserved Structured OSV record; not marked as GitHub-reviewed.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-hj95-mhgf-jxc4 lists affected ranges: PyPI executorch >=0 =0 <0.7.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-hj95-mhgf-jxc4 lists affected ranges: PyPI executorch >=0 =0 <0.7.0 (fixed); not tracked by Patchnext: SwiftURL
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2025-30404: 0.63% estimated exploitation activity in the next 30 days; percentile 50.34 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
An integer overflow vulnerability in the loading of ExecuTorch models can cause overlapping allocations, potentially resulting in code execution or other undesirable effects. This issue affects ExecuTorch prior to commit d158236b1dc84539c1b16843bc74054c9dcba006.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 4 · amended ·
Amended from osv record GHSA-hj95-mhgf-jxc4
- Revision 3 · amended ·
Amended from ghsa record GHSA-hj95-mhgf-jxc4
- Revision 2 · amended ·
Amended from ghsa record GHSA-hj95-mhgf-jxc4
- Revision 1 · created ·
Published from osv record PYSEC-2026-335
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-30404 Advisory: ExecuTorch integer overflow vulnerability IDs: CVE-2025-30404, GHSA-hj95-mhgf-jxc4 Record: https://patchnext.com/advisories/cve-2025-30404 (revision 4, source checked 28 Oct 2026, 06:05 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.pytorch:executorch-android 0.7.0; executorch 0.7.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.pytorch:executorch-android: affected < 0.7.0; fixed in 0.7.0 - PyPI executorch: affected < 0.7.0; fixed in 0.7.0 ## Suggested inspection (read-only) - Maven org.pytorch:executorch-android: check the installed version with your package manager. - `python -m pip show executorch`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.pytorch:executorch-android, executorch. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/PYSEC-2026-335 (OSV record PYSEC-2026-335 lists affected ranges: PyPI executorch >=0 <0.7.0 (fixed)) - Verified: https://github.com/advisories/GHSA-hj95-mhgf-jxc4 (GitHub-reviewed advisory GHSA-hj95-mhgf-jxc4 lists affected ranges: PyPI executorch >=0 =0 <0.7.0) - Verified: https://osv.dev/vulnerability/GHSA-hj95-mhgf-jxc4 (OSV record GHSA-hj95-mhgf-jxc4 lists affected ranges: PyPI executorch >=0 =0 <0.7.0 (fixed); not tracked by Patchnext: SwiftURL) Commands are suggestions: review each one before running it.
Loading voting…