Skip to content

← Public intelligence

PyPI package

epyt-flow

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Critical, CVSS 10.0PyPIAmendedPublished

    EPyT-Flow vulnerable to unsafe JSON deserialization (__type__)

    CVE-2026-25632 · GHSA-74vm-8frp-7w68

    Affected
    • PyPI epyt-flow < 0.16.1
    Fixed in
    0.16.1· Vendor fix available
    Issue
    Impact EPyT-Flow’s REST API parses attacker-controlled JSON request bodies using a custom deserializer (my_load_from_json) that supports a type field. When type is present, the deserializer dynamically imports an attacker-specified module/class and instantiates it with attacker-supplied arguments. This allows invoking dangerous classes such as subprocess.Popen, which can lead to OS command execution during JSON parsing. This also affects the loading of JSON files. Patches EPyT-Flow has been patched in 0.16.1 -- affects all versions <= 0.16.0 Workarounds Do not load any JSON from untrusted sources and do not expose the REST API. Credits EPyT-Flow thanks Jarrett Chan (@syphonetic) for detecting and reporting the bug.

    Recommended action: Upgrade to 0.16.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.com (1)osv.dev (2)Source checked Evidence →