Skip to content

← Actionable
Critical, CVSS 10.0amended

EPyT-Flow vulnerable to unsafe JSON deserialization (__type__)

CVE-2026-25632GHSA-74vm-8frp-7w68

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (epyt-flow 0.16.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
10.0 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
EPSS
  • CVE-2026-25632: 0.80% estimated exploitation activity in the next 30 days; percentile 56.46 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact EPyT-Flow’s REST API parses attacker-controlled JSON request bodies using a custom deserializer (my_load_from_json) that supports a type field. When type is present, the deserializer dynamically imports an attacker-specified module/class and instantiates it with attacker-supplied arguments. This allows invoking dangerous classes such as subprocess.Popen, which can lead to OS command execution during JSON parsing. This also affects the loading of JSON files.

Patches EPyT-Flow has been patched in 0.16.1 -- affects all versions <= 0.16.0

Workarounds Do not load any JSON from untrusted sources and do not expose the REST API.

Credits EPyT-Flow thanks Jarrett Chan (@syphonetic) for detecting and reporting the bug.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 5 · amended ·

    Amended from osv record GHSA-74vm-8frp-7w68

  2. Revision 4 · amended ·

    Amended from ghsa record GHSA-74vm-8frp-7w68

  3. Revision 3 · amended ·

    Amended from ghsa record GHSA-74vm-8frp-7w68

  4. Revision 2 · amended ·

    Amended from osv record GHSA-74vm-8frp-7w68

  5. Revision 1 · created ·

    Published from ghsa record GHSA-74vm-8frp-7w68

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-25632

Advisory: EPyT-Flow vulnerable to unsafe JSON deserialization (__type__)
IDs: CVE-2026-25632, GHSA-74vm-8frp-7w68
Record: https://patchnext.com/advisories/cve-2026-25632 (revision 5, source checked 28 Oct 2026, 06:10 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 10.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: epyt-flow 0.16.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI epyt-flow: affected < 0.16.1; fixed in 0.16.1

## Suggested inspection (read-only)
- `python -m pip show epyt-flow`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on epyt-flow.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-74vm-8frp-7w68 (GitHub-reviewed advisory GHSA-74vm-8frp-7w68 lists affected ranges: PyPI epyt-flow >=0 <0.16.1)
- Verified: https://osv.dev/vulnerability/GHSA-74vm-8frp-7w68 (OSV record GHSA-74vm-8frp-7w68 lists affected ranges: PyPI epyt-flow >=0 <0.16.1 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…