Skip to content

← Public intelligence

PyPI package

docassemble

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. UnratedPyPIAmendedPublished

    Unauthorized access through URL manipulation

    GHSA-qrmm-w4v4-q7f8

    Affected
    • PyPI docassemble < 1.2.65
    Fixed in
    1.2.65· Vendor fix available
    Issue
    Impact The vulnerability allows attackers to gain unauthorized access to information on the system through URL manipulation. Patches The vulnerability has been patched in version 1.2.65 of the master branch, version 1.1.113 of the 1.1.x series, and version 1.0.12 of the stable branch. The Docker image on docker.io has been patched. Workarounds If upgrading is not possible, manually apply the changes of https://github.com/jhpyle/docassemble/commit/e3dbf6ce054b3c0310996f0657289f5eed0a73fe and restart the server (e.g., by pressing Save on the Configuration screen). Credit The vulnerability was discovered by Jim Platania of Seiso LLC (@jimmio). For more information If you have any questions or comments about this advisory: Open an issue in docassemble Join the Slack channel Email us at jhpyle@gmail.com

    Recommended action: Upgrade to 1.2.65 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →